WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5274 closed defect (bug) (invalid)

Automatic pingback comments created for blog post that link to blog pages on the local blog

Reported by: Skywing Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.3.1
Component: General Keywords:
Focuses: Cc:

Description

I've noticed that, at least with WP 2.3.1, if I have create a page and then create a blog post that has a link to the page, WP will automagically post a pingback comment to the page.

This is a bit odd though, as you can't see comments on pages except through the administrative interface and the comments RSS feed (at least to my knowledge). The only way I even noticed it was that I got one of the usual comment notification mails for a pingback comment that happened to be associated with the page in question after I posted a new blog entry.

I don't remember for certain if I've seen this behavior for pre-2.3.1 WP; I don't think that I've linked to a page before, but I can't confirm that with complete certainty.

Given that pages don't usually seem to be designed to allow comments to be displayed, this seems a lil bit broken to me.

Change History (2)

comment:1 @westi8 years ago

  • Resolution set to invalid
  • Status changed from new to closed

This is by design.

Pages support comments fine if your theme disables them.

comment:2 @westi8 years ago

  • Milestone 2.5 deleted
Note: See TracTickets for help on using tickets.