WordPress.org

Make WordPress Core

Opened 5 months ago

Last modified 5 months ago

#52771 reopened defect (bug)

5.7 issue p tag added to html comment

Reported by: fjcontrib Owned by:
Milestone: Priority: normal
Severity: critical Version: 5.7
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

5.7 issue p tag added to html comment in editor (classic) this creates leaded gaps in display therefore throwing out design layouts. Have downgraded to 5.6.2 until solution confirmed. Thank you for the good work. Fred

Change History (7)

#2 @SergeyBiryukov
5 months ago

  • Milestone changed from Awaiting Review to 5.7.1

Hi there, welcome to WordPress Trac!

Thanks for the report, moving to 5.7.1 for investigation.

This ticket was mentioned in Slack in #forums by vladytimy. View the logs.


5 months ago

This ticket was mentioned in Slack in #forums by alanfuller. View the logs.


5 months ago

#5 @SergeyBiryukov
5 months ago

  • Keywords needs-patch removed
  • Milestone 5.7.1 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This appears to be the same issue as in #52764, which has a bit more information. Let's continue the discussion there.

#6 @fjcontrib
5 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

No - my ticket is just about p tags being added to html comments <--. The other thread is of no use to me.

#7 @SergeyBiryukov
5 months ago

  • Keywords reporter-feedback added

Just noting that while the initial #52764 description is about media embeds, the issue is not limited to that, and can happen with any <p></p> tags that were not previously visible on the page, but are visible now. See also comment:10:ticket:52764 for a bit more details.

As noted in comment:6:ticket:52764, this is due to the change to block library paragraph styles in PR 27995.

If you add this to Appearance → Customize → Additional CSS as a workaround, as suggested in comment:12:ticket:52764, does that fix the issue for you?

body p:empty:before {
	content: none;
}
Last edited 5 months ago by SergeyBiryukov (previous) (diff)
Note: See TracTickets for help on using tickets.