Make WordPress Core

Opened 3 years ago

Closed 2 months ago

#52772 closed defect (bug) (worksforme)

Twenty Twenty-One: Block editor from adds overlap option by default to columns

Reported by: shapesgraphicstudio's profile shapesgraphicstudio Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: reporter-feedback close
Focuses: Cc:

Description

When I create a new columns block, the editor adds the overlap option by default, so the class “is-style-twentytwentyone-columns-overlap” gets added.

I do not want this, but I can’t seem to get rid of it although the class is not in my inc/block-patterns.php file.

I’m using a created child theme for Twenty Twenty One theme (latest version updated on 2021/03/11.

The documentation (https://wordpress.org/support/article/twenty-twenty-one/#overlapping-columns) mentions "an optional style called overlap" but I get it by default.

Attachments (1)

columns-block-sidebar.png (32.9 KB) - added by sabernhardt 2 years ago.

Download all attachments as: .zip

Change History (6)

#1 @sabernhardt
2 years ago

Hi and thanks for the report!

Could you follow these steps to make sure the process works for you (now)?

  1. Add a Columns block.
  2. Navigate to the Columns container block, either by clicking "Columns" in the bottom breadcrumbs or by locating it in the block tree ("List view").
  3. Open the sidebar panel (gear icon) if it was not already.
  4. Change the "Default Style" from "Overlap" to "Not set" if possible.
  5. Create another Columns block and verify whether that has the "Default" option selected (outlined) and "Not set" for the "Default Style" setting.

#2 @sabernhardt
2 years ago

  • Keywords reporter-feedback added

#3 @desrosj
23 months ago

  • Summary changed from Block editor from adds overlap option by default to columns to Twenty Twenty-One: Block editor from adds overlap option by default to columns

#4 @karmatosed
2 months ago

  • Keywords close added

As confirmed by @sabernhardt I am also unable to reproduce an issue today. This likely is something was fixed by time, which is great so my recommendation is we can add the close keyword and wrap this ticket up.

Should anyone wish to counter that please add your voice to this ticket and thank you everyone for collaborating on this.

#5 @karmatosed
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Let's close this for now as it's had time to get feedback. Thank you everyone.

Note: See TracTickets for help on using tickets.