WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5280 closed defect (bug) (duplicate)

cannot use "tag" as permalink base for categories

Reported by: azizpoonawalla Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: tags, categories
Focuses: Cc:

Description

Prior to v2.3.x I had been using the URL base "tags" for my category permalinks, as follows:

<a href="http://www.haibane.info/tags/stranger-than-fiction/">http://www.haibane.info/topic/stranger-than-fiction/</a>

which would return the list of all posts categorized as "stranger than fiction" on my weblog. This is set by the Options:Permalinks menu. The benefit to this was that categories were indexed as tags by Technorati without having to install a full-fledged tag plugin (which was otherwise essentially redundant with existing WP category functionality).

After upgrading to WP 2.3.1 (from v2.2, bypassing v2.3) the link above returns a 404. It seems that the text strings "tag" or "tags" (tag* ?) are reserved only for tags and may not be used for categories. Is this intentional or a bug in how the namespace is designed?

Since you may not have a tag and a category with identical names, there seems no reason for such a limitation to exist. 2.3.x now adds an option to specify the permalink base for cats and for tags separately (sugested as "topics" for the former and "tags" for the latter). If such an option is given to the user, why not permit arbitrary strings; even the perverse case where the permalink base is "categories" for tags and "tags" for categories.

I did attempt to specify the same string for both permalink bases ("tag"). There was no objection from Wordpress, it allowed me to save the setting without error, but the URL above attempting to retrieve all posts from a given category still returned a 404 (and worked fine for a tag example).

My specific feature request for v2.3.2 is that no hidden constraints be placed on what string we choose for permalink bases for either categories or tags. Whether a user chooses all tags, all cats, or some combination of both, or what they desire in their URL permalinks, should be entirely user-determined and no predefined preferences should be hard-coded (by design or accident) into the system.

Change History (2)

comment:1 azizpoonawalla6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 foolswisdom6 years ago

  • Milestone 2.3.2 deleted
Note: See TracTickets for help on using tickets.