WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#5283 closed enhancement (duplicate)

Apostrophe not allowed in local-part of email address

Reported by: johndeery Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: apostrophe, sanitize
Focuses: Cc:

Description

Currently, WP will not allow an apostrophe character in the local-part of an email addresss, so someone with an email like john.o'connor@… will not be allowed.

According to RFC 2822, however:

...the local-part of the e-mail may use any of these ASCII characters:

  • Uppercase and lowercase letters
  • The digits 0 through 9
  • The characters,! # $ % & ' * + - / =? _ ` { ¦ } ~
  • The character "." provided that it is not the first or last character in the local-part.

Originally posted in the MU trac system, was requested to be posted here, so if it has already been resolved, I apologize.

Change History (3)

comment:1 Bobcat6 years ago

Should be part of #4616.

comment:2 ninjaWR5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #4616

comment:3 ninjaWR5 years ago

  • Milestone 2.9 deleted
Note: See TracTickets for help on using tickets.