WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

#52873 closed defect (bug) (wontfix)

Reusable Blocks

Reported by: hicklingadmin Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.7
Component: Editor Keywords:
Focuses: Cc:

Description

Hi!
I have upgraded to 5.7 and I'm having difficulty with the reusable blocks.
Previously if you inserted a reusable block and then changed your mind, you simply used 'remove block' and it went from the page you were editing but it didn't affect the block anywhere else on the site.
Now if you 'remove block' the block is just completely deleted from everywhere!
I am an amateur (which is why I use WordPress) but I cannot find a way around this happening and I am tearing my hair out!
Please could you let me know if this is the software or something that I am doing wrong!

Change History (7)

#1 @peterwilsoncc
6 months ago

  • Component changed from Formatting to Editor
  • Milestone changed from Awaiting Review to 5.7.1
  • Severity changed from major to normal
  • Version set to 5.7

Hi @hicklingadmin and welcome to trac!

Thanks for your report, I'm moving this on to the 5.7.1 milestone for further investigation and visibility. As a next step, someone will try to reproduce the issue following the steps you've provided above (thank you!). If the person testing has any questions, they'll get back to you on this ticket.

#2 @talldanwp
6 months ago

@hicklingadmin I tested and couldn't reproduce the issue you mentioned, but I do see how this might be caused by a confusing user interface.

Prior to 5.7 when a reusable block was added to a post it couldn't be directly edited. A distinct 'edit' button had to be clicked to unlock the reusable block.

Since 5.7 though, a reusable block can be directly edited. There's no separate edit mode. It might be that you were accidentally removing the block inside the reusable block if you had the wrong block selected, and then saving that change would update the reusable block everywhere.

If that's right, I'd recommend using the breadcrumb at the bottom of the screen to make sure the reusable block is selected before deleting.

There are ideas to improve this:

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


6 months ago

#4 @hicklingadmin
6 months ago

Dear Daniel,

Many thanks for your reply - that's really helpful; and seems to explain the issue.

It is horribly easy to make this mistake, though; any chance of a return to specifically having an edit button?!!

Can you answer a separate query for me, whilst you're there?

When uploading media we've always had an upload limit of 50mb, this has suddenly gone down to 2mb which is causing problems - we do use image & pdf resizers to limit what is held within the site.

Do you know why this has changed and how we can alter it back?

Thank you!!
Best wishes,

Jane.

#5 @hicklingadmin
6 months ago

Dear Daniel,
Just a quick message to say that I've sorted out the upload issue - it was from a PHP update, now corrected.
Thank you!
Jane

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


6 months ago

#7 @audrasjb
6 months ago

  • Milestone 5.7.1 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Hello,

I'm going to close this issue as wontfix, not because the ticket is irrelevant, but because it is a general design issue and it needs to be discussed upstream on the Gutenberg repository. I know this resolution keyword may sound a bit rude, but that's just a workflow keyword, it doesn't mean we don't need to talk about this issue anymore.

Please have a look on the issue on Gutenberg repository, I think your feedback would really help:)
https://github.com/WordPress/gutenberg/issues/27890

Thanks

Note: See TracTickets for help on using tickets.