WordPress.org

Make WordPress Core

Opened 7 weeks ago

Closed 6 weeks ago

#52902 closed defect (bug) (reported-upstream)

Cannot remove logo in Theme Customizer once it's been added

Reported by: bradley2083 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.7
Component: Customize Keywords:
Focuses: Cc:

Description

My guess is this is a core WP issue, but not sure where to post it if it is. In either case, I've noticed on all sites I have admin access to that are on the latest versions of WP that if you add a custom logo in Theme Customizer, save, then view, the logo is there. However, if you then open up the customizer menu and remove the logo, the real-time update works, but when you Publish and view the site, the old logo is still there.

I've been able to replicate this with no plugins and just the default theme installed across multiple different sites. If I completely delete the logo file from the media, then nothing appears (i.e. not even the text version of the site name).

Here's a quick video showing that I add a logo successfully, then try to remove it and save but the logo continues to appear:
https://soapbox.wistia.com/videos/VMOWaROoWo

Cheers,

Change History (3)

#1 @hellofromTonya
7 weeks ago

  • Keywords reporter-feedback added

Hello @bradley2083,

Welcome to WordPress Core Trac! Thank you for the report and for the video showing the problem in action. Very helpful.

I was unable to reproduce the problem (see my notes below) using a fresh 5.7 installation, Twenty Twenty-One theme, and no plugins or must-use plugins/scripts activated. Tried in multiple browsers.

To help with further investigation, please try the following:

  • Try in a different browser such as Firefox and/or use incognito mode in Chrome (command + shift + n). Does the problem persist?
  • Change the old logo to a different logo. Does the new one appear? If old one, it may be custom CSS, script, or caching.

Please check the following for the environment:

  • Are there any must-use plugins/scripts?
  • Is there caching in your localhost environment?
  • Are there any errors in the error.log or debug.log?
  • Are there any errors in the browser's console?
  • Does the problem persist when on a live site? Or is it only when local on your machine?

My Testing

Steps:

  1. From front-end, click on "Customize" link in admin bar
  2. Click on "Site identity"
  3. Add a logo, site title, and tagline
  4. Publish
  5. Close to return to front-end. Expected Behavior: logo, site title, and tagline should all render/appear
  6. Click "Customize" link in admin bar
  7. Click on "Site identity"
  8. Remove the logo and change the site title
  9. Publish
  10. Close to return to front-end. Expected Behavior: logo should be gone, but new site title with the tagline should render/appear

My Environment:

  • Browsers: Chrome v89.0.4389.90 (regular and incognito), Firefox v86.0.1 and v87.0, Firefox Developer v88.0b2, and Safari v14.0.3
  • OS: macOS Big Sur v11.2.3
  • Plugins: none
  • Theme: Twenty Twenty-One
  • WordPress: fresh install of 5.7
  • LocalHost: Local

Observations:

  • Logo rendered as expected
  • After removing, logo did not render as expected
  • No errors in each of the browser consoles
  • No errors in the error.log

#2 @bradley2083
6 weeks ago

@hellofromTonya Thanks for the reply. I just realized this issue only occurs with the Gutenberg plugin active. I'll try to get my initial ticket in the Gutenberg Github repo re-open. Thanks!

#3 @hellofromTonya
6 weeks ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Thanks @bradley2083 for sharing when it happens. I can reproduce the issue when the plugin is activated. The Gutenberg issue is reopened https://github.com/WordPress/gutenberg/issues/30152.

Closing this issue here in Trac as it's reported upstream.

Note: See TracTickets for help on using tickets.