WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 7 weeks ago

Last modified 7 weeks ago

#52915 closed defect (bug) (fixed)

Replace unknown user login text with something more readable

Reported by: dd32 Owned by: desrosj
Milestone: 5.8 Priority: normal
Severity: normal Version:
Component: Login and Registration Keywords: has-patch has-screenshots commit
Focuses: ui-copy Cc:

Description

The error text when you attempt to login with an invalid username isn't very clear:

Unknown username. Check again or try your email address.

"Check Again"? Check what? "Check your email"?

Unlike with an incorrect password (or empty password), the username is also not prefilled which leads to more confusion as the end-user cannot even see that they typo'd their username.

As this is an error message that's intended to be displayed to end-users more often than others, I would suggest that this error message should be far more helpful.

Perhaps something like:

Username Unknown. The username <strong>admin</strong> is not registered on this site. If you're unsure of your username, you can attempt to login using your email address instead.

Attachments (3)

Screen Shot 2021-03-26 at 12.47.37 pm.png (274.4 KB) - added by dd32 4 months ago.
52915.diff (726 bytes) - added by audrasjb 7 weeks ago.
Patch
Capture d’écran 2021-06-08 à 22.40.18.png (110.1 KB) - added by audrasjb 7 weeks ago.
testing the proposed patch

Download all attachments as: .zip

Change History (12)

#1 @SergeyBiryukov
4 months ago

  • Milestone changed from Awaiting Review to 5.8
  • Owner set to SergeyBiryukov
  • Status changed from new to accepted

It looks like the message was improved in [46417] / #43037, but could still use some further clarification.

Let's start by reinstating the "Error:" prefix for consistency. Related: #52914.

#2 @SergeyBiryukov
4 months ago

In 50589:

Login and Registration: Restore the "Error:" prefix for the "Unknown username" message.

This makes the message more consistent with other error messages related to authentication and registration.

Follow-up to [46417].

Props dd32.
See #52914, #52915.

@audrasjb
7 weeks ago

Patch

@audrasjb
7 weeks ago

testing the proposed patch

#3 @audrasjb
7 weeks ago

  • Keywords has-patch has-screenshots added

Hello,
This is a pretty straightforward patch, but I think it's a good idea to clarify the error. The proposed patch fixes the issue. Let's try this small enhancement for 5.8!

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


7 weeks ago

#5 @desrosj
7 weeks ago

  • Owner changed from SergeyBiryukov to desrosj
  • Status changed from accepted to assigned

This ticket was mentioned in Slack in #core by desrosj. View the logs.


7 weeks ago

#7 @desrosj
7 weeks ago

  • Keywords commit added

I like the idea here. But I felt what's currently in the patch is a bit too long. After some discussion in #core, we arrived at "Error: The username X is not registered on this site. If you are unsure of your username, try your email address."

#8 @desrosj
7 weeks ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 51126:

Login and Registration: Improve the unknown username error message

The new message is more clear and makes the next step more clear to the user.

Props dd32, SergeyBiryukov, audrasjb, desrosj, dlh, marybaum, chanthaboune, jeffpaul.
Fixes #52915.

#9 @lkraav
7 weeks ago

Not sure whether core has any copywriting language conventions, but starting sentences with "The" continues to look awkward, mostly creating noise / distraction for minimal value add.

Better: "Username %s ...", so user can immediately see what the problem is, instead of digging through language article soup.

Note: See TracTickets for help on using tickets.