WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#52946 closed enhancement (duplicate)

Replace deprecate @babel/polyfill package

Reported by: gziolo Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.8
Component: External Libraries Keywords:
Focuses: javascript Cc:

Description (last modified by gziolo)

Extracted from #52854.

Related issues in Gutenberg repository with more details: https://github.com/WordPress/gutenberg/issues/22417.

According to https://babeljs.io/docs/en/babel-polyfill, @babel/polyfill got deprecated

It looks like we need to create a webpack entry point that imports core-js and regenerator-runtime.

import 'core-js/stable';
import 'regenerator-runtime/runtime';

They aren't defined as dependencies in package.json at the moment.

Change History (3)

#1 @gziolo
8 months ago

  • Description modified (diff)

#2 @ocean90
8 months ago

  • Milestone 5.8 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #52941.

#3 @gziolo
8 months ago

I missed that. I commented on the ticket opened by @desrosj :)

Note: See TracTickets for help on using tickets.