WordPress.org

Make WordPress Core

Opened 14 years ago

Last modified 6 years ago

#5294 closed defect (bug)

$phpmailer->Sender line prevents comment notifications from being received — at Version 12

Reported by: stitzelj Owned by: westi
Milestone: Priority: normal
Severity: normal Version: 2.3.1
Component: General Keywords:
Focuses: Cc:

Description (last modified by foolswisdom)

$phpmailer->Sender line prevents comment notifications from being received on hosts that do "callout verification" unless wordpress@[domain] is a valid email address.

WORKAROUNDS

Ensure, that the email address wordpress@[domain] is a valid email address.

OR

Remove wp-includes/pluggable.php file in WP 2.3.1:

228  $phpmailer->Sender = apply_filters( 'wp_mail_from', $from_email ); 

Change History (12)

#1 @Viper007Bond
14 years ago

  • Milestone changed from 2.5 to 2.3.2
  • Version set to 2.3.1

Works just fine for me, so it must be a server configuration thing.

#2 @stitzelj
14 years ago

Hm, that figures. And I have no control over server settings, so I guess I'll just have to tag that line out everytime I upgrade from now on.

#3 @foolswisdom
14 years ago

stitzelj, hopefully not, the trick is figuring out why it doesn't work for you, and how general the problem is.

#4 @stitzelj
14 years ago

Any suggestions on what I can check on my end are welcome.

#5 @foolswisdom
14 years ago

My guess is this relates to #5273, and "callout verification". If you create an email address of wordpress@[blogdomain] do you receive the comments? (Or update $from_email in pluggable.php to be equal to an existing email address)

#6 @stitzelj
14 years ago

Neither of those corrected the problem.

#7 @stitzelj
14 years ago

As it turns out, ticket #5273 that you pointed out is a problem for me, as well. I have a multi-author blog I'm also running that takes new contributors as they come, and neither of the last two that have signed up (both since I upgraded to 2.3.1) have received their verification emails and get email server connection errors when they try to request a new email with a password.

#8 @westi
14 years ago

  • Owner changed from anonymous to westi
  • Status changed from new to assigned

#9 follow-up: @danahuff
14 years ago

I am having the same problem, and it appears that the e-mails being sent out to people who subscribe to my blog might not be receiving them. I had quite a few bounced e-mails in my main box.

#10 @stitzelj
14 years ago

Problem solved once I set up the wordpress@[domain] email address. I messed up the initial setup of the account earlier, which is why it didn't seem to fix the problem. I've re-uploaded the original 2.3.1 version of the pluggable.php file, and it works fine. Apparently, the original root email address that was set up when bought my account was no longer adequate when I upgraded to 2.3.1.

#11 in reply to: ↑ 9 @foolswisdom
14 years ago

Followed up with danahuff by email, and her issue doesn't seem to relate. It seems to be a hosting issue.

#12 @foolswisdom
14 years ago

  • Description modified (diff)
  • Summary changed from $phpmailer->Sender line prevents comment notifications from being sent to $phpmailer->Sender line prevents comment notifications from being received
Note: See TracTickets for help on using tickets.