WordPress.org

Make WordPress Core

Changes between Initial Version and Version 1 of Ticket #53016


Ignore:
Timestamp:
04/12/2021 07:08:34 AM (8 months ago)
Author:
dd32
Comment:

Hi @kraevit,

The function in question should only be called when the blog visibility option is enabled, or another plugin is causing it to be called.

The functionality is controlled through the following setting under Settings -> Reading:

Search engine visibility	Discourage search engines from indexing this site

If that option is disabled, you should check where the function is being called from (It's new in 5.7), as I suspect it'll be being called from a plugin. The only place that calls it in WordPress that would affect most urls is wp_robots_noindex().

Without knowing which URLs are affected or why it's being called, it's not possible to determine if this is a WordPress issue or not, but it doesn't appear that it's likely to be a core bug due to the newness of the functionality and that more people aren't affected by it.

Unfortunately I'm closing this as invalid as there's no information which can be used to replicate it or point to the cause being WordPress itself.

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #53016

    • Property Keywords reporter-feedback added; needs-testing removed
    • Property Status changed from new to closed
    • Property Resolution changed from to invalid
    • Property Milestone changed from Awaiting Review to
  • Ticket #53016 – Description

    initial v1  
    11Hello,
    2 My name is Krasimir Kraev, I have frustrating issue with my wordpress installation version 5.7 using yoast seo plugin. My google search console reported that i have 1600 invalid url's due to having "noindex" in the <meta robots tag> of my pages/posts. Everything in the admin panel is set correctly(eg settings reading). I found that in this particular file of wordpress core files - /wp-includes/robots-template.php in the lines from 153-165 there is a function:
     2My name is Krasimir Kraev, I have frustrating issue with my wordpress installation version 5.7 using yoast seo plugin. My google search console reported that i have 1600 invalid url's due to having "noindex" in the <meta robots tag> of my pages/posts. Everything in the admin panel is set correctly(eg settings reading). I found that in this particular file of wordpress core files - /wp-includes/robots-template.php in the lines from 153-165 there is a function:
     3{{{
    34function wp_robots_no_robots( array $robots ) {
    45
     
    1415        return $robots;
    1516}
     17}}}
    1618
    1719Is this a bug or it is a normal wordpress 5.7 behavior?