Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#53059 closed enhancement (fixed)

Coding Standards: Give some variables in WP_Widget_Pages a more meaningful name

Reported by: mukesh27's profile mukesh27 Owned by: davidbaumwald's profile davidbaumwald
Milestone: 5.8 Priority: normal
Severity: normal Version:
Component: Widgets Keywords: has-patch commit
Focuses: coding-standards Cc:


In widget WP_Widget_Pages it use $out variable. As per Coding Standards, we should use some meaningful name like $output

Change History (7)

This ticket was mentioned in PR #1196 on WordPress/wordpress-develop by mukeshpanchal27.

3 years ago

  • Keywords has-patch added

#2 @SergeyBiryukov
3 years ago

  • Milestone changed from Awaiting Review to 5.8

#3 @SergeyBiryukov
3 years ago

  • Keywords commit added

#4 @SergeyBiryukov
3 years ago

  • Owner set to davidbaumwald
  • Status changed from new to assigned

#5 @desrosj
3 years ago

Thanks so much for this ticket and patch, @mukesh27!

In the future when reporting coding standards issues like this, please try to review entire files at a time and detail which files you reviewed when you discovered the issue. For example, I just reviewed the other classes in wp-includes/widgets for this same issue, and it seems the only occurrence is in WP_Widget_Pages.

Changes like this are also really great for adding the good-first-bug keyword to. It's important to leave some easier tickets for contributors just getting involved with WordPress so that there are tickets they can feel confident jumping into!

Also, every release has a coding standards improvement task. For 5.8, it's #52627. If there are small, one off changes like this, they can be posted on the task ticket for the current release. It helps group all of the coding standards related changes in one place for future reference.

#6 @mukesh27
3 years ago

@desrosj Thank you.

I Will take care of this for future tickets.

#7 @davidbaumwald
3 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 50797:

Coding Standards: Update $out in WP_Widget_Pages with a more meaningful name.

Rename an $out variable to $output for consistency with other widget classes..

Props mukesh27.
Fixes #53059.

Note: See TracTickets for help on using tickets.