WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 5 months ago

#53086 closed defect (bug) (invalid)

width and height attributes for block editor images

Reported by: asafm7 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:

Description

Jetpack Image CDN automatically fetches resized images according to the image 'width' and 'height' attributes for better performance.

'width' and 'height' attributes aren't produced for block editor images - and there is no apparent way to manually set it.

Am I missing something?

Change History (2)

#1 @asafm7
5 months ago

So I realized I prevent thumbnail sizes with code.

If I enable it, I can choose between the preset sizes.

But still, as the thumbnail files themself aren't needed when using Jetpack Image CDN, a way to set width and height without generating thumbnail files would be great

#2 @desrosj
5 months ago

  • Component changed from General to Media
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @asafm7,

Thanks for this ticket! I'm sorry you are having some issues with images on your site.

This Trac instance is for discussing bugs in WordPress itself. While it is possible there is a bug in WordPress Core that needs fixing, it's more likely that the issue you are experiencing is because of Jetpack.

I recommend reaching out in the Support Forums on WordPress.org.

If a WordPress specific bug is discovered, feel free to reopen this with details how to reproduce without Jetpack active.

Note: See TracTickets for help on using tickets.