WordPress.org

Make WordPress Core

Opened 7 weeks ago

Closed 6 weeks ago

Last modified 6 weeks ago

#53095 closed defect (bug) (duplicate)

WordPress generated (large) Sitemap returns 404 error

Reported by: nicmare Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.5
Component: Sitemaps Keywords:
Focuses: Cc:

Description

Wordpress' sitemap generates a pagebreak after 2000 entries. The first page works but every other page after that not. Example:
https://mybricks.net/wp-sitemap.xml
contains:

Focus on these three items:

  1. https://mybricks.net/wp-sitemap-posts-brick_set-1.xml
  2. https://mybricks.net/wp-sitemap-posts-brick_set-2.xml
  3. https://mybricks.net/wp-sitemap-posts-brick_set-3.xml

Google Search Console reads first one without problems but returns 404 on 2 and 3. I can confirm i am not able to download 2 and 3 in the browser. I get an error from chrome "Error – no file". But i can see it in the browser. Strange behavior.

https://i.ibb.co/hC6c1tk/image.png

Change History (4)

#1 @sabernhardt
6 weeks ago

  • Focuses accessibility removed

#2 @sabernhardt
6 weeks ago

It might be related to

  • nginx and/or
  • custom post type settings

#3 @peterwilsoncc
6 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 5.7.1 to 5.5

@sabernhardt @nicmare I've added some additional notes #51912 with the details reported here that indicate it's an issue for sites with a large number of posts for a CPT. If I've missed anything, please feel free to add a comment. The issue here is also related to #51117.

The root cause of this is the same as that reported in #51912, so I'll close this ticket as a duplicate to keep discussion in one place.

#4 @nicmare
6 weeks ago

thank you peter. did not find anything related to my issue but glad that i am not the only one

Note: See TracTickets for help on using tickets.