Make WordPress Core

Opened 9 months ago

Closed 6 months ago

#53211 closed defect (bug) (reported-upstream)

Changes to a reusable block are not reflected when using the post preview functionality

Reported by: thomasplevy Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:

Description

Recreation Steps

  1. Visit a post/page
  2. Add a preexisting reusable block to the content of the post/page
  3. Update the post/page
  4. Make a change to the content of the reusable block added in step 2
  5. Use the "Preview" -> "Preview in new tab" button to view the post preview

Expected Behavior

In the new tab I would expect the changes made to the reusable block (step 4) to be reflected in the preview

Actual Behavior

The changes made in step 4 are not reflected in the preview.

Attached gif demonstrating the above steps

I've considered that behavior I'm encountering is potentially the actual expected behavior given that the reusable block (wp_block) post is what's been edited and therefore no changes have actually been made to the the post/page itself. But I felt it worthwhile to at the very least raise this issue as it feels a bit confusing to me and I had to actually unpack the functionality to explain to myself what was happening (and why).

I'm also not sure if this should be reported to the Gutenberg project on GitHub or here. If I'd be better off reporting this over there I'll move it over.

Thanks!

Attachments (1)

Peek 2021-05-14 14-18.gif (2.4 MB) - added by thomasplevy 9 months ago.
demonstration of observed behavior/issue

Change History (4)

@thomasplevy
9 months ago

demonstration of observed behavior/issue

#1 @thomasplevy
7 months ago

I've duplicated this to the Gutenberg GitHub https://github.com/WordPress/gutenberg/issues/32864

I know having duplicates isn't appreciated but I am not sure where the right place to report this is

This ticket was mentioned in Slack in #core by jeffpaul. View the logs.


6 months ago

#3 @desrosj
6 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed
  • Version trunk deleted

Thanks for this ticket @thomasplevy!

I am going to close this one out because the issue will need to be addressed in the Gutenberg repository before any action can be taken here. This seems like it may be an intentional behavior as part of the multi-entity saving flow, which is still being reviewed for ways to improve.

Note: See TracTickets for help on using tickets.