WordPress.org

Make WordPress Core

Opened 2 months ago

Last modified 2 months ago

#53255 reopened defect (bug)

WordPress multisite allows you to delete plugins which are active on some subdomains

Reported by: denisflorin197 Owned by:
Milestone: Awaiting Review Priority: normal
Severity: critical Version: 4.6
Component: Plugins Keywords: needs-patch
Focuses: administration, multisite Cc:

Description

Hello,

I remember in the past, WordPress was not allowing you to delete a plugin that is active at least on one website.

Change History (3)

#1 @SergeyBiryukov
2 months ago

  • Component changed from General to Plugins
  • Focuses administration multisite added
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi there, welcome to WordPress Trac! Thanks for the report.

As far as I can tell, this has always been the case, we're already tracking this issue in #31673.

#2 @denisflorin197
2 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Hello,

But, I don't see any warnings. The only thing I get is that if I want to remove the plugin. See video: https://www.loom.com/share/d69900d4098e4bebbefc80b307bbdfb8

Thanks,

#3 @SergeyBiryukov
2 months ago

  • Keywords needs-patch added
  • Milestone set to Awaiting Review
  • Version changed from 5.7.2 to 4.6

Thanks for the additional details! Indeed, I was able to reproduce the issue.

The warning is still in core, but it looks like it's no longer displayed, apparently due to the "Shiny Updates" changes introduced in [37714] for WordPress 4.6.

Note: See TracTickets for help on using tickets.