Make WordPress Core

Opened 3 years ago

Closed 13 months ago

Last modified 13 months ago

#53269 closed defect (bug) (worksforme)

Reusable Blocks container is not accessible when it's the first top block

Reported by: giorgio25b's profile Giorgio25b Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.7.2
Component: Editor Keywords: reporter-feedback close
Focuses: ui, accessibility, css Cc:

Description

The Reusable Blocks container is not accessible when it's the first top block and the mouse over won't highlight the wrapping container (.block-editor-block-contextual-toolbar-wrapper) and the block details:
https://griccardi.com/wordpress-images/block-editor-block-contextual-toolbar-wrapper.png.

Pressing the Tab key will highlight it, as well creating an empty <p> block as first element on top will allow for the mouse over.

Here a clumsy screen-cast to prove my point:
https://griccardi.com/wordpress-images/block-editor-block-contextual-toolbar-wrapper.mov

Not sure this helps, but this ticket here seems kind of related:
https://core.trac.wordpress.org/ticket/52918

Change History (14)

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


3 years ago

#2 @ryokuhi
3 years ago

  • Keywords reporter-feedback added

Hello @Giorgio25b, and thanks for reporting this issue.
We checked this ticket today during the weekly Accessibility Team's bug-scrub, we have a few difficulties in understanding how we can help.
Could you please add the following details?

  • Do you use the Gutenberg plugin? If yes, which version?
  • Are you still able to reproduce the issue when using the default theme (Twenty Twenty-One) and after disabling all plugins (excluding Gutenberg, if installed)?
  • What should be the expected behaviour?
  • Can you add a list of instructions to follow to replicate the issue?

After we are able to reproduce the issue, we'll report it upstream to the Gutenberg GitHub repository, where it'll be solved.

Last edited 3 years ago by ryokuhi (previous) (diff)

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


3 years ago

#4 @ryokuhi
3 years ago

Hello again, @Giorgio25b.
We're waiting for your input regarding this issue.
If you can get back to us with any additional information by next week, we'll decide how to push this issue forward, otherwise we'll close this ticket until we get extra information.

#5 @Giorgio25b
3 years ago

@ryokuhi Hello,
I just tested again on 2 different installations:
WP 5.7.2 with latest Gutenberg plugin version 10.8.2 installed and WP 5.8 Beta 01 with nightly build and Gutenberg plugin activated. Both environments are using WP2021 theme latest build.
I confirm the previous findings and issues, but with a slightly improved situation
I'll try to explain the expected behaviour and what is happening in reality:
On an empty new post if the first block is a re-usable block and the convert to regular block button is not pressed right away, it will not be possible to retrieve the convert to regular block btn anymore.

  • Create a reusable block: title+text or title+img
  • Create a new post
  • Add reusable block right away
  • Do NOT press convert to regular blocks
  • Add another block below
  • Try to scroll up and mouseover to retrieve the convert to regular blocks btn
  • Now, with latest Gutenberg plugin version, pressing tab on the keyboard from the post title activates the convert to regular blocks btn.
  • Mouseover still does not allow it.

I understand this is an edge scenario, but less skilled users (clients of mine) are not able to grasp an easy solution because they'd expect to just mouseover and get a consistent behaviuor regardless of the reusable block position within the post content.

Hope this helps!

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


3 years ago

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


2 years ago

This ticket was mentioned in Slack in #accessibility by alexstine. View the logs.


2 years ago

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


13 months ago

#10 @joedolson
13 months ago

  • Resolution set to fixed
  • Status changed from new to closed

As of today, I was unable to reproduce this problem in 6.3 alpha with Gutenberg following the reproduction steps above. If you are still encountering it, please feel free to re-open, as I can't provide a citation of where and when this issue was fixed.

#11 @sabernhardt
13 months ago

  • Component changed from General to Editor
  • Keywords needs-patch 2nd-opinion removed

It might be related to GB29332.

#12 @SergeyBiryukov
13 months ago

  • Milestone Awaiting Review deleted
  • Resolution changed from fixed to worksforme

#13 @Giorgio25b
13 months ago

  • Keywords close added

re-tested on WP 6.3-alpha-5569 and I can not replicate the issue any longer.
Toolbar improvements and new editor experience in 6.2 now made this ticket irrelevant.
Thank you!

#14 @joedolson
13 months ago

Thanks for confirming, @Giorgio25b!

Note: See TracTickets for help on using tickets.