WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 2 months ago

#53277 closed task (blessed) (fixed)

Bump default theme versions for WordPress 5.8

Reported by: mukesh27 Owned by: desrosj
Milestone: 5.8 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch commit fixed-major dev-reviewed
Focuses: Cc:

Description

The release of 5.8 will be accompanied by a release for each maintained default theme:

Twenty Twenty-One: 1.4
Twenty Twenty: 1.8
Twenty Nineteen: 2.1
Twenty Seventeen: 2.8
Twenty Sixteen: 2.5
Twenty Fifteen: 3.0
Twenty Fourteen: 3.2
Twenty Thirteen: 3.4
Twenty Twelve: 3.4
Twenty Eleven: 3.8
Twenty Ten: 3.4

The versions need to be bumped appropriately.

Attachments (1)

53277.diff (28.2 KB) - added by kapilpaul 4 months ago.
Bundled Themes: Bump theme version numbers for WordPres 5.8.

Download all attachments as: .zip

Change History (13)

#1 @desrosj
4 months ago

  • Owner desrosj deleted

This ticket was mentioned in Slack in #core by jeffpaul. View the logs.


4 months ago

@kapilpaul
4 months ago

Bundled Themes: Bump theme version numbers for WordPres 5.8.

This ticket was mentioned in PR #1342 on WordPress/wordpress-develop by kapilpaul.


4 months ago

  • Keywords has-patch added; needs-patch removed

This updates all-new default themes to new versions, which will be released shortly after WordPress 5.8. The new versions are:

  • Twenty Twenty-One: 1.4
  • Twenty Twenty: 1.8
  • Twenty Nineteen: 2.1
  • Twenty Seventeen: 2.8
  • Twenty Sixteen: 2.5
  • Twenty Fifteen: 3.0
  • Twenty Fourteen: 3.2
  • Twenty Thirteen: 3.4
  • Twenty Twelve: 3.4
  • Twenty Eleven: 3.8
  • Twenty Ten: 3.4

Trac Ticket: https://core.trac.wordpress.org/ticket/53277

#4 @desrosj
4 months ago

Thanks @kapilpaul!

We'll evaluate this closer to 5.8 release day.

This ticket was mentioned in Slack in #core by jeffpaul. View the logs.


3 months ago

#6 @desrosj
3 months ago

  • Keywords commit added
  • Owner set to desrosj

I gave this a review today and confirmed that every theme does in fact have changes. As of ~24 hours ago, all of them now do.

Marking this for commit as the bumps all look good to me. However, let's hold off on committing until the release dry run the day before.

This ticket was mentioned in Slack in #core by jeffpaul. View the logs.


3 months ago

This ticket was mentioned in Slack in #core by jeffpaul. View the logs.


3 months ago

#9 @desrosj
2 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 51455:

Bundled Themes: Bump bundled theme versions for WordPress 5.8.

This bumps the version for all bundle themes in preparation for release with WordPress 5.8. The new versions are as follows:

  • Twenty Twenty-One: 1.4
  • Twenty Twenty: 1.8
  • Twenty Nineteen: 2.1
  • Twenty Seventeen: 2.8
  • Twenty Sixteen: 2.5
  • Twenty Fifteen: 3.0
  • Twenty Fourteen: 3.2
  • Twenty Thirteen: 3.4
  • Twenty Twelve: 3.4
  • Twenty Eleven: 3.8
  • Twenty Ten: 3.4

Props mukesh27, kapilpaul.
Fixes #53277.

#10 @desrosj
2 months ago

  • Keywords dev-feedback fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for backport.

#11 @peterwilsoncc
2 months ago

  • Keywords dev-reviewed added; dev-feedback removed

[51455] looks good to me for merging to the 5.8 branch.

  • Versions match in each location for all themes
  • 2019, 2020 have had generated files updated
  • Changelogs added with correct pages linked

Note: reviewed on GitHub as trac doesn't display all the changes due to the size of the commit, see d69216bf5

These changes will need to be committed to the theme repository on update. This can either be done by meta or core committers.

#12 @desrosj
2 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 51457:

Bundled Themes: Bump bundled theme versions for WordPress 5.8.

This bumps the version for all bundle themes in preparation for release with WordPress 5.8. The new versions are as follows:

  • Twenty Twenty-One: 1.4
  • Twenty Twenty: 1.8
  • Twenty Nineteen: 2.1
  • Twenty Seventeen: 2.8
  • Twenty Sixteen: 2.5
  • Twenty Fifteen: 3.0
  • Twenty Fourteen: 3.2
  • Twenty Thirteen: 3.4
  • Twenty Twelve: 3.4
  • Twenty Eleven: 3.8
  • Twenty Ten: 3.4

Props mukesh27, kapilpaul, peterwilsoncc.
Merges [51455] to the 5.8 branch.
Fixes #53277.

Note: See TracTickets for help on using tickets.