Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 2 months ago

#53281 closed defect (bug) (worksforme)

Bug in hyperlink unlink block editor

Reported by: oisraelo's profile oisraelo Owned by:
Milestone: Priority: normal
Severity: major Version: 5.7.2
Component: Editor Keywords: has-screenshots reporter-feedback
Focuses: ui, accessibility, javascript, rtl, performance, ui-copy Cc:

Description

Hi, there is a bug with hyperlink unlink button, I’m trying to quickly remove the hyperlink from text in visual block editor without deleting the text but I am not able to, I can’t delete or remove a hyperlink without having to deleting the whole block or edit as html. This wasn’t happening till recent, How do I go about this? Please help Thanks!

It works on the top links but not the bottom, I attached photos
https://ibb.co/qgNFdNX
https://ibb.co/kBrpywF

Change History (8)

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


3 years ago

#2 @ryokuhi
3 years ago

  • Keywords reporter-feedback added

Hello @oisraelo, thanks for reporting this issue and welcome on Trac.
We checked this ticket today during the weekly Accessibility Team's bug-scrub, we have a few difficulties in understanding how we can help.
Could you please add the following details?

  • Do you use the Gutenberg plugin? If yes, which version?
  • Are you still able to reproduce the issue when using the default theme (Twenty Twenty-One) and after disabling all plugins (excluding Gutenberg, if installed)?
  • Can you add a list of instructions that we can follow to reproduce the issue?

After we are able to reproduce the issue, we'll report it upstream to the Gutenberg GitHub repository, where it'll be solved.

Last edited 3 years ago by ryokuhi (previous) (diff)

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


3 years ago

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


3 years ago

#5 @ryokuhi
3 years ago

Hello again, @oisraelo.
We're waiting for your input regarding this issue.
If you can get back to us with any additional information by next week, we'll decide how to push this issue forward, otherwise we'll close this ticket until we get extra information.

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


3 years ago

#7 @joedolson
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Since we've been unable to reproduce this issue, we're closing the ticket. Feel free to reopen if you have more information about it.

#8 @vizvizka
2 months ago

Hello Oisraelo

1.Sometimes conflicts with plugins or themes can cause unexpected behavior in WordPress. Temporarily deactivate all plugins and switch to a default WordPress theme (such as Twenty Twenty-One). Then, try removing the hyperlink again to see if the issue persists. If it doesn't, reactivate your plugins and theme one by one until you identify the culprit.

2.Cached data or cookies in your web browser can sometimes cause issues with the functionality of WordPress. Try clearing your browser cache and cookies, then reload the WordPress editor and attempt to remove the hyperlink again.

3.Sometimes issues can be browser-specific. Try using a different web browser to see if you're able to remove the hyperlink without any issues.

4.Ensure that your WordPress installation, plugins, and themes are all up to date. Developers often release updates to fix bugs and improve compatibility, so updating to the latest versions may resolve the issue.

5.In some cases, using keyboard shortcuts can help bypass issues with buttons in the WordPress editor. Try selecting the text with the hyperlink and then use the keyboard shortcut for removing a hyperlink. On most systems, this is usually Ctrl + Shift + K (or Cmd + Shift + K on Mac).

Note: See TracTickets for help on using tickets.