Make WordPress Core

Opened 3 years ago

Last modified 46 hours ago

#53314 accepted defect (bug)

Add Themes page in UI issue

Reported by: sumitsingh's profile sumitsingh Owned by: audrasjb's profile audrasjb
Milestone: 6.7 Priority: normal
Severity: normal Version: 5.7.2
Component: Themes Keywords: has-patch has-screenshots has-testing-info
Focuses: ui, css, administration Cc:

Description

Hi ,

i have found some small issue on IPhone on add new theme page on admin side.

More information you can see mentioned screenshot.

Thank you

Attachments (4)

Add Themes ‹ C (1).png (45.4 KB) - added by sumitsingh 3 years ago.
Your WordPress.org username: on button alignment issue
Add Themes ‹ C (2).png (47.6 KB) - added by sumitsingh 3 years ago.
Edit Filters screen
Mobile - add themes - Screenshot-1.jpg (81.6 KB) - added by krupajnanda 4 days ago.
Mobile - add themes -Screenshot - 2.jpg (96.8 KB) - added by krupajnanda 4 days ago.

Download all attachments as: .zip

Change History (20)

@sumitsingh
3 years ago

Your WordPress.org username: on button alignment issue

@sumitsingh
3 years ago

Edit Filters screen

#1 follow-up: @gauravtiwari
3 years ago

iPhone uses ubuntu font?

#2 in reply to: ↑ 1 ; follow-up: @sumitsingh
3 years ago

Hi,

What the reply 😂🤣

Any device in check responsive on any Operating system by Developer. I think you are not a developer otherwise you can understand with screenshot.

Replying to gauravtiwari:

iPhone uses ubuntu font?

#3 in reply to: ↑ 2 @gauravtiwari
3 years ago

  • Resolution set to invalid
  • Severity changed from normal to trivial
  • Status changed from new to closed

No need to get offended. The thing is that virtual devices and dev tools' device screenshots work differently than original devices.

My iPhone uses SFUi font.

Can you please confirm which iOS version you are using? Maybe your safari is outdated.

Replying to sumitsingh:

Hi,

What the reply 😂🤣

Any device in check responsive on any Operating system by Developer. I think you are not a developer otherwise you can understand with screenshot.

Replying to gauravtiwari:

iPhone uses ubuntu font?

Last edited 3 years ago by gauravtiwari (previous) (diff)

This ticket was mentioned in Slack in #core by gauravtiwari. View the logs.


3 years ago

#5 @gauravtiwari
3 years ago

  • Resolution invalid deleted
  • Severity changed from trivial to normal
  • Status changed from closed to reopened

#6 @sabernhardt
3 years ago

  • Keywords needs-patch added

The filter tags list could be fixed by adding display: inline-block, and I would prefer removing the 11px font size.

I also think the username label, input and button would be better stacked vertically—with a margin between them—at the 782px breakpoint.

#7 @sumitsingh
3 years ago

Any update abouth this ticket Guys?

This ticket was mentioned in PR #6874 on WordPress/wordpress-develop by @Benjamin_Zekavica.


4 weeks ago
#8

  • Keywords has-patch added; needs-patch removed

#9 @Benjamin_Zekavica
4 weeks ago

  • Keywords needs-testing added

@sumitsingh I fixed it by using flexbox. See here: https://github.com/WordPress/wordpress-develop/pull/6874

#10 @audrasjb
4 weeks ago

  • Milestone changed from Awaiting Review to 6.7
  • Owner set to audrasjb
  • Status changed from reopened to accepted

#11 @krupajnanda
4 days ago

  • Keywords has-screenshots has-testing-info added; needs-testing removed

Hi,

Test Report

Description

This report validates whether the indicated PR works as expected.

PR tested: https://github.com/WordPress/wordpress-develop/pull/6874

Environment

  • WordPress: 6.6-beta3-58440-src
  • PHP: 8.2.15
  • Server: nginx/1.25.3
  • Database: mysqli (Server: 8.0.36 / Client: mysqlnd 8.2.15)
  • Browser: Chrome 126.0.0.0
  • OS: macOS
  • Theme: Twenty Twenty-Four 1.1
  • MU Plugins:
    • Safe Autoloaded Options Limit Test (MU Plugin) 1.0
  • Plugins:
    • Test Reports 1.1.0

Actual Results

  1. ✅ Issue resolved with added fix in the given PR.

I tested this with multiple devices and looks like Pr works as intended.

Supplemental Artifacts

Add as Attachment

#12 @Benjamin_Zekavica
4 days ago

@krupajnanda Thank you so much for testing :) You're awesome, good job.
@audrasjb I think it's ready to merge to the Core SVN, or you have some feedback?

@Benjamin_Zekavica commented on PR #6874:


3 days ago
#13

@sabernhardt Thank you :) I will update it later and submit a new patch

#14 @Benjamin_Zekavica
3 days ago

@sabernhardt I approved your code suggestions, I hope now it's fine ?

#15 @krupajnanda
2 days ago

@krupajnanda Thank you so much for testing :) You're awesome, good job.

Thank you! 🙇‍♀️

@Benjamin_Zekavica Please let me if this is required an another round for testing.

#16 @Benjamin_Zekavica
46 hours ago

@krupajnanda It would be good to test it again with the new version of the patch. Thank you :)

Note: See TracTickets for help on using tickets.