WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#53350 closed feature request (duplicate)

User experience deleting many menu items

Reported by: sentinel777 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Menus Keywords:
Focuses: Cc:

Description

for menus with lots of items (like after importing theme demo content) it takes a lot of time deleting them by opening the dropdown, finding the delete button and click on it.

why cant we delete menu items by focusing and pressing DEL key on the keyboard? or an "trash" area to drag and drop menu items to delete them.

a faster delete mechanism would make the user experience of wordpress 1% better ;)

thank you!

Change History (3)

#1 @audrasjb
6 months ago

  • Component changed from General to Menus
  • Keywords close added

Hi @sentinel777 and welcome to WordPress Trac,

A bulk deletion feature was added in WP Core few days ago :)
See ticket #21603 for more info. It will be introduced by WP 5.8.

You can test the feature on a test site using WP Beta Tester plugin.

#2 @audrasjb
6 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

#3 @SergeyBiryukov
6 months ago

  • Resolution changed from worksforme to duplicate

Duplicate of #21603.

Note: See TracTickets for help on using tickets.