WordPress.org

Make WordPress Core

Opened 8 weeks ago

Closed 2 weeks ago

Last modified 39 hours ago

#53367 closed defect (bug) (fixed)

Update the $_old_files array for 5.8

Reported by: desrosj Owned by: desrosj
Milestone: 5.8 Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords: has-patch commit fixed-major dev-reviewed
Focuses: Cc:

Description

The $_old_files array needs to be updated for 5.8.

While updating to the 5.8 Beta 1 package to test during the packaging process, the following was returned:

Starting update...
Downloading update from https://wordpress.org/wordpress-5.8-beta1.zip...
Unpacking the update...
Cleaning up files...
File removed: wp-includes/css/dist/editor/editor-styles-rtl.css
File removed: wp-includes/css/dist/editor/editor-styles-rtl.min.css
File removed: wp-includes/css/dist/editor/editor-styles.css
File removed: wp-includes/css/dist/editor/editor-styles.min.css
File removed: wp-includes/blocks/subhead/block.json
File removed: wp-includes/block-patterns/quote.php
File removed: wp-includes/block-patterns/three-buttons.php
File removed: wp-includes/block-patterns/heading-paragraph.php
File removed: wp-includes/block-patterns/two-buttons.php
File removed: wp-includes/block-patterns/large-header.php
File removed: wp-includes/block-patterns/text-two-columns.php
File removed: wp-includes/block-patterns/text-three-columns-buttons.php
File removed: wp-includes/block-patterns/large-header-button.php
File removed: wp-includes/block-patterns/two-images.php
File removed: wp-includes/block-patterns/text-two-columns-with-images.php
15 files cleaned up.
Success: WordPress updated successfully.

These files being "old" needs to be confirmed and added to the array accordingly.

Attachments (2)

53367.diff (1.1 KB) - added by kapilpaul 8 weeks ago.
added files in the $_old_files
53367.2.diff (701 bytes) - added by desrosj 2 weeks ago.

Download all attachments as: .zip

Change History (17)

@kapilpaul
8 weeks ago

added files in the $_old_files

This ticket was mentioned in PR #1356 on WordPress/wordpress-develop by kapilpaul.


8 weeks ago

  • Keywords has-patch added; needs-patch removed

This PR contains an update of $_old_files array.

Trac Ticket: https://core.trac.wordpress.org/ticket/53367

#2 @desrosj
8 weeks ago

  • Keywords commit added

Thanks @kapilpaul! This looks good with a few adjustments that I'll make when committing.

First, we'll just want to alphabetize the list so that everything is in a logical order. And second, it looks like the wp-includes/blocks/subhead directory was also removed. That will also need to be added to the list.

#3 @kapilpaul
8 weeks ago

Hi @desrosj

wp-includes/blocks/subhead the full directory removed??

I am only seeing wp-includes/blocks/subhead/block.json in the log which you have shared.

Last edited 8 weeks ago by kapilpaul (previous) (diff)

#4 @desrosj
8 weeks ago

It was! The log above was just to share the output from WP CLI when updating. The best way to fully check for all deleted files and directories is using SVN and is
in the release documentation.

For this release, running the following command will do the trick.

svn diff --summarize https://core.svn.wordpress.org/tags/5.7 https://core.svn.wordpress.org/trunk | grep '^D'

#5 @desrosj
8 weeks ago

  • Owner set to desrosj
  • Resolution set to fixed
  • Status changed from new to closed

In 51133:

Upgrade/Install: Update the $_old_files list for 5.8.

Follow up to [50761], [50794], [51021].
Props kapilpaul, desrosj.
See #52991, #52846, #53246.
Fixes #53367.

#6 @kapilpaul
8 weeks ago

@desrosj

Thanks for explaining this. :)

#7 @desrosj
8 weeks ago

In 51134:

Upgrade/Install: Built files should not be included in the $_old_files list.

Follow up to [51133].
Unprops desrosj.
See #53367.

@desrosj
2 weeks ago

#8 @desrosj
2 weeks ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Looks like there are a few more files to add to the list related to the About page edits (see #52775). 53367.2.diff takes care of that.

Since 5.8 has been branched, the new command is svn diff --summarize https://core.svn.wordpress.org/tags/5.7 https://core.svn.wordpress.org/branches/5.8 | grep '^D'.

I've also verified that all new files do not share a name with any listed in $_old_files using svn diff --summarize https://core.svn.wordpress.org/tags/5.7 https://core.svn.wordpress.org/branches/5.8 | grep '^A'.

#9 @desrosj
2 weeks ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 51459:

Upgrade/Install: Add additional files to $_old_files for 5.8.

Follow up to [51134].

Fixes #53367.

#10 @desrosj
2 weeks ago

  • Keywords dev-feedback fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening to backport [51459] to the 5.8 branch.

#11 @peterwilsoncc
2 weeks ago

  • Keywords dev-reviewed added; dev-feedback removed

[51459] looks good for backport to me, review process:

  • Install WP 5.7
  • Run wp core update https://wordpress.org/nightly-builds/wordpress-latest.zip to install the nightly
  • verify each of the files above are removed, they are.

I'm going to take another look at [51134] doing a standard (in WP upgrade) as I am not clear on why the built files shouldn't be removed.

#12 @peterwilsoncc
2 weeks ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 51460:

Upgrade/Install: Add additional files to $_old_files for 5.8.

Follow up to [51134].

Props desrosj.
Merges [51459] to the 5.8 branch.
Fixes #53367.

#13 @desrosj
13 days ago

After looking further with @peterwilsoncc, it does seem that the files removed from the list in [51134] do in fact belong in the list. However, there is a bug in grunt verify:old-files that is incorrectly flagging them.

I've opened #53687 as a followup for that.

The $_old_files list is iterated through every time a site updates, so these files can be added in 5.8.1 and they will be removed appropriately.

Note: See TracTickets for help on using tickets.