WordPress.org

Make WordPress Core

Opened 6 weeks ago

Closed 5 weeks ago

#53433 closed defect (bug) (fixed)

The New Widgets in 5.8 compatibility issue

Reported by: oglekler Owned by:
Milestone: 5.8 Priority: normal
Severity: normal Version: 5.8
Component: Widgets Keywords: has-screenshots
Focuses: Cc:

Description

The New Widgets with WooCommerce 5.1.0. are not showing up at all. I've checked with WC 5.3.0 and the latest 5.4.0 - visually it's ok, but errors in the console are the same (look at screenshots).

A suppose that similar compatibility problems can raise with other plugins and themes which use widgets and people will come to .org Support for answers.

Attachments (2)

2021-06-16_20-21-53.png (43.6 KB) - added by oglekler 6 weeks ago.
The New Widgets with WooCommerce 5.1.0. are not showing up
2021-06-16_19-52-08.png (46.5 KB) - added by oglekler 6 weeks ago.
Errors in the console

Download all attachments as: .zip

Change History (14)

#1 @desrosj
6 weeks ago

  • Milestone changed from Awaiting Review to 5.8

@oglekler
6 weeks ago

The New Widgets with WooCommerce 5.1.0. are not showing up

@oglekler
6 weeks ago

Errors in the console

#2 @desrosj
6 weeks ago

  • Keywords has-screenshots added

#4 @oglekler
6 weeks ago

@bobbingwide I am not sure. I see the bigger problem here - if something happening on this screen with WooCommerce, other plugins and themes can have compatibility problems in this area as well and people will blame the Core update when this will happen.

I think the solution could have been like "Old widget area" and "New widget area" - if something isn't working right in this New area, explain to the user that he/she needs to check with plugins & theme developers about compatibility and the option to switch temporarily to the "Old widget area". Of course, most users will do nothing and just switch to Old version, but it will reduce the amount of poor feedback.

This ticket was mentioned in Slack in #core by jeffpaul. View the logs.


6 weeks ago

#6 @JeffPaul
6 weeks ago

@oglekler can you confirm what blocks you were expecting to see there? As @bobbingwide noted, the Cart and Checkout blocks are purposefully hidden from the widget editor by WooCommerce. So if those are the blocks you're expecting, then this seems like things working as expected (with maybe some error handling needed from the WooCommerce team). If there are other blocks missing that you're expecting to see, then please confirm so we can continue to triage this with you... thanks!

#7 @desrosj
6 weeks ago

  • Keywords reporter-feedback added

#8 @aljullu
6 weeks ago

Thanks for the report @oglekler, what you are seeing is a combination of two different issues.

The New Widgets with WooCommerce 5.1.0. are not showing up at all.

This was fixed in WooCommerce 5.2.0, it was caused by one of our CSS files expecting a dependency that was missing in the Site Editor. You can read more details in this issue:

https://github.com/woocommerce/woocommerce-gutenberg-products-block/issues/3626

I've checked with WC 5.3.0 and the latest 5.4.0 - visually it's ok, but errors in the console are the same (look at screenshots).

This is an issue which appeared recently with WordPress 5.8 beta 2. That's because we are relying on a polyfill that was removed from WP core. We are tracking this in this PR:

https://github.com/woocommerce/woocommerce-gutenberg-products-block/pull/4362

And it's also being discussed in this ticket:

https://core.trac.wordpress.org/ticket/52941

Depending on the resolution of the ticket, we might push a fix to WC 5.5 after feature-freeze.

#9 @desrosj
6 weeks ago

Hey everyone! If @aljullu's assumption that the changes to the wp-polyfill script are causing this issue is correct, it should be fixed after [51212].

@oglekler can you please give this another round of testing using trunk, or beta 3 once it's released in a few hours?

#10 @desrosj
5 weeks ago

Hi @oglekler, just checking if you have had a chance to re-test this one. Thanks!

#11 @oglekler
5 weeks ago

Hi @desrosj with the latest version of WooCommerce (5.4.1) all seems to work, but Ultimate Addons for Gutenberg (version 1.23.4) blocks are not working in Widgets (I made an issue on their GitHub). I wonder if we can notify all plugins and themes authors who are using widgets or have blocks 🙈 to check compatibility?

The 5.8 loads frontend scripts in Widgets what was only expected in Customizer previously and because of it, these scripts can cause errors as well. I have tested on a site I am about to finish and found that I didn't check the existence of an element before handling it assuming that it's in the header and always exists. I can not be the only one 😅

#12 @desrosj
5 weeks ago

  • Keywords reporter-feedback removed
  • Resolution set to fixed
  • Status changed from new to closed

Thanks @oglekler! I think there are a few more developer notes planned related to the new Widget area with some best practice guidance.

But since there are no more action items here currently, I am going to close this out as fixed through [51212].

Note: See TracTickets for help on using tickets.