WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#53454 closed defect (bug) (duplicate)

Widgets screen: blocks should inherit their style from the editor stylesheet provided by the theme

Reported by: audrasjb Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Widgets Keywords:
Focuses: css Cc:

Description

At least on Twenty Twenty-One, it looks like all the text blocks inserted within the new Widgets screen are using a default serif font family.

It seems to fallback to this CSS rule by default:

.editor-styles-wrapper {
    font-family: serif;
}

I guess we should inherit all the block editor styling from this Bundled theme. But more importantly, we should probably find a way to inherit this from the block editor stylesheet if there is already one declared by the theme :)

Attachments (1)

Capture d’écran 2021-06-19 à 00.12.13.png (100.4 KB) - added by audrasjb 3 months ago.
Texts with serif font-family

Download all attachments as: .zip

Change History (3)

@audrasjb
3 months ago

Texts with serif font-family

#1 @desrosj
3 months ago

  • Keywords reporter-feedback close added; needs-patch removed

I think this is covered in the report of #53388, which was closed in favor of three more targeted issues. #53344 seems like it would fix this issue.

@audrasjb if that seems right to you as well, feel free to close this one as a duplicate!

#2 @audrasjb
3 months ago

  • Keywords reporter-feedback close removed
  • Milestone 5.8 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #53344.

Alright! For some reason I wasn't able to find any ticket about this specific styling issue.

Note: See TracTickets for help on using tickets.