Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#53460 closed defect (bug) (reported-upstream)

There are no blocks in the block inserter, when you press the Add Block button in the widget area on the Widgets screen.

Reported by: thingsym's profile thingsym Owned by: kevin940726's profile kevin940726
Milestone: Priority: normal
Severity: normal Version: 5.8
Component: Widgets Keywords: needs-patch
Focuses: Cc:

Description

Describe the bug

When there are no blocks in the widget area, I can't select a block because the block list is not displayed in the block inserter.

To Reproduce

Steps to reproduce the behavior:

  1. Make sure there are no blocks in the widget area of the Widgets screen
  2. Click Add block button
  3. The blank toolbar just disappears and nothing happens
  4. Click Add block button again, the floated block inserter is displayed
  5. Click Browse all, the block inserter is displayed
  6. The block list is not displayed in the block inserter, you can only search

Expected behavior

  • The block inserter should display the block list.
  • Need the initial block Type / to choose a block in the widget area, if the widget area is blank.

Solution

It seems that the cause is that there is no block in the initial state in the widget area, so it is better to prepare the initial block Type / to choose a block like the post screen.

Additional context

  • WordPress version 5.8-beta2
  • Twenty Twenty-One Version: 1.3

Attachments (1)

screencast-widgets-screen.mov (692.1 KB) - added by thingsym 2 years ago.
widgets screen screencast

Download all attachments as: .zip

Change History (9)

@thingsym
2 years ago

widgets screen screencast

#1 @desrosj
2 years ago

  • Component changed from General to Widgets
  • Milestone changed from Awaiting Review to 5.8

Moving to the milestone for investigation.

#2 @johnbillion
2 years ago

  • Keywords needs-testing added

#3 @desrosj
2 years ago

  • Keywords needs-patch added; needs-testing removed

Thanks for this report @thingsym.

I am still able to reproduce this on a fresh beta 3 install.

When the widget area is empty, the block insterter is indeed empty. This happens regardless of whether there were blocks in the sidebar when the page loaded.

I'm going to flag this with the editor team for further investigation.

This ticket was mentioned in Slack in #core-editor by desrosj. View the logs.


2 years ago

#6 @noisysocks
2 years ago

  • Owner set to kevin940726
  • Status changed from new to assigned

#7 @noisysocks
2 years ago

  • Milestone 5.8 deleted
  • Resolution set to reported-upstream
  • Status changed from assigned to closed

The fix looks like it should be entirely upstream so closing this in favour of GB32931.

#8 @desrosj
2 years ago

#53498 was marked as a duplicate.

Note: See TracTickets for help on using tickets.