WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#53463 closed defect (bug) (fixed)

Lazy loading attribute not adding to images in block based widgets

Reported by: spacedmonkey Owned by: flixos90
Milestone: 5.8 Priority: normal
Severity: normal Version: 5.8
Component: Widgets Keywords: has-patch has-unit-tests commit
Focuses: Cc:

Description

If I insert an image or paragraph / custom html ( that contains html for an image ), in the new block based widget screen, the generated image on the front end does contain the loading="lazy" attribute. See attached screenshot.

Attachments (1)

Screenshot 2021-06-20 at 15.44.19.png (210.5 KB) - added by spacedmonkey 3 months ago.

Download all attachments as: .zip

Change History (10)

#1 @spacedmonkey
3 months ago

  • Summary changed from Lazy loading images not working in block based widgets to Lazy loading attribute not adding to images in block based widgets

This ticket was mentioned in Slack in #core-media by spacedmonkey. View the logs.


3 months ago

#3 @spacedmonkey
3 months ago

I should just be a matter of running

add_filter( 'widget_block_content', 'wp_filter_content_tags' );

This ticket was mentioned in PR #1401 on WordPress/wordpress-develop by walbo.


3 months ago

  • Keywords has-patch has-unit-tests added; needs-patch removed

#5 @walbo
3 months ago

Adding wp_filter_content_tags will also add the missing srcset/sizes in #53464

#7 @daisyo
3 months ago

Confirmed that the issue is present and tested the patch. Works as expected.

Markup Before:
https://d.pr/i/nIRRgg

Markup After
https://d.pr/i/sim5Yf

#8 @flixos90
3 months ago

  • Keywords commit added
  • Owner set to flixos90
  • Status changed from new to reviewing

Thanks @daisyo for the testing! Both PRs fix it correctly, but https://github.com/WordPress/wordpress-develop/pull/1401 also has a little test coverage. This is ready for commit.

#9 @flixos90
3 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 51207:

Media: Add lazy-loading support to block-based widgets.

This changeset adds the wp_filter_content_tags() function as a filter to widget_block_content.

Props spacedmonkey, walbo, daisyo.
Fixes #53463, #53464.

Note: See TracTickets for help on using tickets.