WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#53498 closed defect (bug) (duplicate)

Browse All functionality in Gutenberg Block not working properly in Widget Section

Reported by: alanjacobmathew Owned by:
Milestone: Priority: normal
Severity: major Version:
Component: Widgets Keywords: needs-patch
Focuses: ui Cc:

Description

Current version: 5.8-beta3-51224, Theme: Twenty Twenty One Default. Local Install
Issue existed for the very previous nightly version too

Description: Gutenberg blocks doesn't work properly in the widgets section.

Steps to reproduce:
1: Appearance -> Widgets
2: Remove all the existing blocks in the Footer widget
3: Click on 'Add new block' -> ' Browse All'

Current Result: No blocks list available for the user, or the sometimes last used blocks only.
Current Images: https://i.imgur.com/rKBMmYd.png No blocks available by default

https://i.imgur.com/4NCT8RB.png No blocks even when searching for

Expected Result: Entire block lists available for the user to choose from. https://i.imgur.com/A3H3Ecv.png

The same issue exists for the inactive widget column also. https://i.imgur.com/Vd93Xvm.png

If the user does not clear the existing blocks in the footer, everything works as expected except the inactive widget section.

Change History (1)

#1 @desrosj
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Severity changed from critical to major
  • Status changed from new to closed

Hi @alanjacobmathew,

Welcome to Trac, and thanks so much for this great report.

This was previously reported in #53460, so I'm going to close this out as a duplicate. That ticket was also closed, but with the reported-upstream resolution. Progress is now being tracked over on https://github.com/WordPress/gutenberg/issues/32931Gutenberg-32931.

Note: See TracTickets for help on using tickets.