WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#53504 closed defect (bug) (duplicate)

Main site Dashboard accessible via multiple paths in multisite network using sub-directories

Reported by: daleharrison Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.7.2
Component: Networks and Sites Keywords: needs-patch
Focuses: multisite Cc:

Description

In a multisite network using the sub-directories approach, it is possible to access the Dashboard of the main site from any of the following URLs:

https://example.com/wp-admin/
https://example.com/any-string/wp-admin/
https://example.com/another-string/wp-admin/

I believe the only URL that should be valid is the first one noted above.

Once on the Dashboard of the main site, you can then navigate to any of the admin panels and the path you used will be respected.

For example, the post editor, Media Library, and General Settings page can be accessed using the following URLs:

https://example.com/any-string/wp-admin/edit.php
https://example.com/any-string/wp-admin/upload.php
https://example.com/any-string/wp-admin/options-general.php

https://example.com/another-string/wp-admin/edit.php
https://example.com/another-string/wp-admin/upload.php
https://example.com/another-string/wp-admin/options-general.php

My hosting environment does not allow me to test if the same happens in a network using the sub-domain approach, but I would be curious to know if this issue also appears there.

Change History (2)

#1 @johnjamesjacoby
3 months ago

  • Keywords needs-patch added

This is somewhat of a known issue, and tends to be specific to the recommended nginx configuration used to make multisite network URLs flexible and friendly.

I would like to see these matches at least redirect to the expected admin URL to avoid confusion, if nothing else.

#2 @jeremyfelt
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I think this is a duplicate of #17376. There are a couple patches and some good discussion on that ticket. I don't remember how close we actually were though. :)

Note: See TracTickets for help on using tickets.