WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#53526 closed defect (bug) (worksforme)

Scroller inside block inserter tool stays at the very bottom WP 5.8-beta4-51244

Reported by: alanjacobmathew Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords: reporter-feedback
Focuses: ui Cc:

Description

WP 5.8-beta4-51244. Theme: Twenty Twenty One. Plugins Installed: None

Consider the user has scrolled to the somewhat the middle in the block inserter tool and then searches for some keyword, the result content, rather than showing all the blocks from the top, scroller stays at the very bottom.

How to reproduce:

1: open an post and click on block inserter.
2: Scroll till the centre/end of toolbar.
3: Search for any block like 'Post' or 'Social' or first letter of some block

Issue: The scroller stays at the bottom, whereas the most accurate results are all on top

Expected Result: The scroller stays on top, where the most accurate block results are.

Attachments (5)

Scroller-in-Block.gif (1.4 MB) - added by alanjacobmathew 5 months ago.
scroller-on-beta4-a.gif (559.1 KB) - added by alanjacobmathew 5 months ago.
Scroller-beta4-b.gif (455.3 KB) - added by alanjacobmathew 5 months ago.
Scroller-on-beta4-c.gif (584.8 KB) - added by alanjacobmathew 5 months ago.
scroller-5.7.2.gif (369.5 KB) - added by alanjacobmathew 5 months ago.

Change History (10)

#1 @SergeyBiryukov
5 months ago

  • Milestone changed from Awaiting Review to 5.8

This ticket was mentioned in Slack in #core-editor by desrosj. View the logs.


5 months ago

#3 @desrosj
5 months ago

  • Keywords reporter-feedback close added

Hi @alanjacobmathew,

Thanks for all of the great testing!

I am having trouble reproducing this issue. I've followed the steps provided and I see the correct expected behavior (block inserter scrolls up to the top and shows the full search results).

Can you try recreating a fresh install and double checking that no plugins are active?

Marking as a close candidate with a worksforme resolution since I am unable to reproduce.

#4 @desrosj
5 months ago

  • Keywords close removed
  • Milestone 5.8 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

#5 @alanjacobmathew
5 months ago

v:5.8-beta4-51247

Hey,

As requested I tried it on fresh install with no plugins.

I was able to reproduce the issue again with the word 'list' (from the second time I searched without reloading the page). I'll attach 3 gifs where the same keyword at different scroll location giving 3 different results(where block scroller doesn't go up).

For what it's worth I was able to reproduce the issue in 5.7.2 stable with the word 'You'.

Note: See TracTickets for help on using tickets.