WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#53582 closed defect (bug) (invalid)

Submit button "use image" text disappears after editing image in dashboard

Reported by: 123host Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.7.2
Component: Media Keywords:
Focuses: Cc:

Description

Using woocommerce I am editing categories and adding a thumbnail to the category. Although I am using WC, this issue seems to be a core WP bug.

I edit the category, click "add/upload image", select an image from the media library and then "edit this image".

I crop the image and then "save". After save the submit button has vanished. It is still there and works, but the text is gone.

Before: https://gyazo.com/0a3468031a81de6f6810b7b30d023985
After: https://gyazo.com/237839856329165d5e9dccba2bea8e1c

Looking in developer tools I see

<button type="button" class="button media-button button-large media-button-select">Use image</button>

before editing and

<button type="button" class="button media-button button-large media-button-select"></button>

after editing.

Change History (2)

#1 @sabernhardt
3 months ago

  • Component changed from General to Media
  • Keywords close 2nd-opinion added

@123host Hi and welcome to WordPress Core Trac!

I was able to reproduce the empty button, but only with the WooCommerce plugin (it adds the image option for product categories). It's probably better to report this on the WooCommerce support forum for them to confirm where the problem is.

The "Use image" button has a "button-primary" class as well, which disappears with the button text when I click Back or Cancel.

<button type="button" class="button media-button button-primary button-large media-button-select">Use image</button>

#2 @sabernhardt
3 months ago

  • Keywords close 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanks for reposting on the support forum!
https://wordpress.org/support/topic/bug-report-submit-button-after-editing-category-image/

I'll close it here. Of course, if it is a core bug, please reopen this ticket.

Note: See TracTickets for help on using tickets.