WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 6 years ago

#5360 closed defect (bug) (worksforme)

Comment editing problem

Reported by: neoen Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.6
Component: General Keywords:
Focuses: Cc:

Description

I was logged as admin and browsing my blog.
As admin I added comment (reply) to my post (http://www.domain.com/category/post-title).
New comment was added successfully (http://www.domain.com/category/post-title#comment-164).
I wanted to edit it once again, I was automatically redirected to admin comment editing page then I edited this comment and in the end I was automatically redirected to strange duplicate address (http://www.domain.com/category/post-title#comment-164#comment-164).

Change History (4)

comment:1 @lloydbudd8 years ago

  • Milestone changed from 2.3.2 to 2.5

Coudn't duplicate this issue on trunk r6336, I'm guessing it relates to your less common permalink structure.

comment:2 @Bobcat8 years ago

I see this problem frequently in 2.3.1 (and previous versions). I saw it with one of the default permalink options. I'm using the veryplaintxt theme, if that matters. The problem is annoying enough that I wrote a plugin filter to strip-out the extra anchor name from the end of the URL.

comment:3 @mrmist7 years ago

  • Version changed from 2.3.1 to 2.6

Confirming this in 2.6.1 beta1.

Repeatable with permalink structure as the raiser had - \%category%\%postname% and default pretty permy structure.
Also repeatable with non-pretty permalinks.

To reproduce -

Create entry, add comment (as admin), edit comment (as admin) save, edit comment (as admin) save. This time it will append and the comment view url will become /?p=56#comment-5comment-5 etc. each subsequent edit will lengthen the url. /?p=56#comment-5comment-5comment-5 and so on.

This only happens if you go directly back in to the edit screen after a previous edit. (I.E two edits in a row). If you leave the post and go back to it, then make the edit, the bug does not appear.

comment:4 @mrmist6 years ago

  • Milestone 2.9 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Now working properly for me in 2.7. Re-open if it can still be reproduced.

Note: See TracTickets for help on using tickets.