WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 12 years ago

#5361 closed defect (bug) (fixed)

Deleting a set front page should then display posts on front page

Reported by: hailin Owned by:
Milestone: 2.5 Priority: normal
Severity: normal Version: 2.5
Component: General Keywords: has-patch
Focuses: Cc:

Description

Create a new page.

Go to Options > reading and set that page as the front page.

Now delete that new page

Front of the blog goes blank.

Expected behaviour: It defaults back to Posts.

============================================
Hailin:
The root cause is the following: Suppose option show_on_front is configured to "page", and page_on_front is set to a specific page_id, and/or page_for_posts is set to another page_id.

Then the user deletes a page from Manage=>Page, which happens to be the configured page_on_front. Then the page is gone, but those options still hold that deleted page_id. That cause the reported problem.

The fix is that when we delete a page, we check to see whether the page is used in any of those options. If yes, we adjust them as well.

Attachments (1)

569_show_on_front.diff (842 bytes) - added by hailin 12 years ago.
patch file

Download all attachments as: .zip

Change History (3)

@hailin
12 years ago

patch file

#1 @lloydbudd
12 years ago

  • Keywords has-patch added
  • Milestone changed from 2.5 to 2.4
  • Version set to 2.4

#2 @ryan
12 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6337]) Update page on front settings when deleting the page on front. Props hailin. fixes #5361

Note: See TracTickets for help on using tickets.