WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#5363 closed defect (bug) (worksforme)

Canonical redirection broken on https://

Reported by: truthmedia Owned by: markjaquith
Milestone: Priority: normal
Severity: normal Version: 2.3.1
Component: General Keywords: https canonical
Focuses: Cc:

Description

On any of our websites running WordPress 2.3 the server gets stuck in an infinite redirection loop when using the https:// protocol.

https://truthmedia.com
https://sandbox3.wearetm.com

When disabling the canonical redirection it works fine.

Both are hosted on MediaTemple, I do not know what type of server they are running, or what redirects they are using, so I cannot tell you what is conflicting.

I have opened a support request asking if they can give me any more info on what is happening behind the scenes.

(If you check and https://truthmedia.com seems to work, that is because I have disabled the canonical redirection, I will leave https://sandbox3.wearetm.com as is for testing though)

Change History (3)

comment:1 lloydbudd6 years ago

  • Milestone set to 2.4
  • Owner changed from anonymous to markjaquith

comment:2 DD325 years ago

I believe the redirection code now supports HTTPS:// correctly? Can someone confirm if this is still an issue? (And with 2.7's skipping of the domain name, shared SSL systems such as my-wordpress.blah.sharedssl.com should work too..)

comment:3 jacobsantos5 years ago

  • Milestone 2.9 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I've tested it and it works fine using https://.

Note: See TracTickets for help on using tickets.