WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 5 months ago

Last modified 5 months ago

#53641 closed defect (bug) (fixed)

Can not configure image widget (and others) in widget accessability mode

Reported by: mark-k Owned by: desrosj
Milestone: 5.8.1 Priority: normal
Severity: normal Version: 5.6
Component: Widgets Keywords: has-patch commit has-screenshots fixed-major
Focuses: accessibility, javascript Cc:

Description

When you get into the accessability mode of the widget screen you can add an image to a side bar, but you don't get any UI to set the title and select an image. Still the same problem after if you try to edit the widget after you have added it.

Seems to be a problem in 5.8 RC2 as well.

Same problem with the custom HTML, gallery, audio and video widgets.

Attachments (5)

Widgets-‹-test-572-—-WordPress.png (82.7 KB) - added by mark-k 6 months ago.
access to accessability mode of the widgets screen, from the "normal" one
Widgets-‹-test-572-2-—-WordPress.png (84.1 KB) - added by mark-k 6 months ago.
Try to add an image widget on that screen
Widgets-‹-test-572-3 -—-WordPress.png (60.4 KB) - added by mark-k 6 months ago.
no ability to set title or select an image
Widgets-‹-test-572-4-—-WordPress.png (69.7 KB) - added by mark-k 6 months ago.
And this is the categories widget at the same mode
53641.diff (984 bytes) - added by sabernhardt 6 months ago.

Download all attachments as: .zip

Change History (20)

#1 @desrosj
6 months ago

  • Keywords reporter-feedback added

Could you provide a bit more detail? I'm not sure what you are referring to when you say the accessibility mode of the widget screen. Is this a browser feature? If so, which browser and version are you using?

Also, you mentioned that the issue also happens in 5.8 RC2, but 5.8 completely overhauls the Widgets screen, so it's not clear if you are using the Classic Widgets plugin or not.

With the new widget screen becoming block-based, titles are no longer included when inserting a new widget. Something similar is being explored in Gutenberg-32723, but what you are explaining seems like the expected behavior.

#2 @desrosj
6 months ago

Possibly related: #53585.

@mark-k
6 months ago

access to accessability mode of the widgets screen, from the "normal" one

@mark-k
6 months ago

Try to add an image widget on that screen

@mark-k
6 months ago

no ability to set title or select an image

@mark-k
6 months ago

And this is the categories widget at the same mode

#3 @mark-k
6 months ago

Sorry, should have been more explicit from the start.

As for blocks, trying to delay seeing the horror, but as long as 6 million sites are going to disable it I assume that bug reports against the "old" widgets screen are meaningful.

#4 @sabernhardt
6 months ago

  • Focuses javascript added
  • Keywords needs-patch added; reporter-feedback removed
  • Milestone changed from Awaiting Review to 5.8.1

In ticket:52073 the Text widget was corrected, and it seems other widgets needed a (possibly similar) fix.

This ticket was mentioned in Slack in #accessibility by sabernhardt. View the logs.


6 months ago

@sabernhardt
6 months ago

#6 @sabernhardt
6 months ago

  • Keywords has-patch needs-testing added; needs-patch removed
  • Version changed from 5.7.2 to 5.6

The patch uses a less specific selector, matching the one in r49973.

(The input is now inside an alignright div as of r49113.)

This ticket was mentioned in Slack in #core-test by boniu91. View the logs.


5 months ago

#8 @alexstine
5 months ago

I just tested 53641.diff and it seems to be working fine. I can see the form to add an image while testing in accessibility mode.

Thanks.

#9 @circlecube
5 months ago

I was able to reproduce the issue and then apply the patch and the issue is resolved. In accessibility mode (using classic widget plugin) the image widget did not allow user to edit the title or add an image because the fields are missing. Applying this patch fixes the issue and the fields are visible in the widget and I was able to both edit title and add media via the keyboard.

#10 @audrasjb
5 months ago

  • Keywords commit has-screenshots added; needs-testing removed
  • Owner set to audrasjb
  • Status changed from new to accepted

Hello,
Just tested 53641.diff: it applies cleanly against trunk and fixes the Media widgets issues currently occurring when using the Classic Widgets Screen’s accessibility mode.

I think this ticket is worth being solved in the next point release.
Marking for commit.

#11 @desrosj
5 months ago

  • Owner changed from audrasjb to desrosj
  • Status changed from accepted to assigned

#12 @desrosj
5 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 51701:

Widgets: Show title and media select fields in Accessibility Mode.

This updates the Custom HTML and Media widgets to display the correct fields when adding or editing a widget when using accessibility mode through the Classic Widgets experience.

Follow up to [49973].

Props mark-k, sabernhardt, alexstine, circlecube, audrasjb.
Fixes #53641.

#13 @desrosj
5 months ago

  • Keywords fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening to backport for 5.8.1.

#14 @desrosj
5 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 51710:

Widgets: Show title and media select fields in Accessibility Mode.

This updates the Custom HTML and Media widgets to display the correct fields when adding or editing a widget when using accessibility mode through the Classic Widgets experience.

Follow up to [49973].

Props mark-k, sabernhardt, alexstine, circlecube, audrasjb.
Merges [51701] to the 5.8 branch.
Fixes #53641.

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


5 months ago

Note: See TracTickets for help on using tickets.