WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#5368 closed defect (bug) (invalid)

It's not possible to replace the RSS parser (MagpieRSS) via a plugin

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.3.1
Component: General Keywords: magpierss
Focuses: Cc:

Description

r5845 doesn't do as intended.

The file wp-includes/rss.php is loaded before plugins are loaded, therefore a plugin isn't able to replace the fetch_rss() function (which was the intention of r5845) as it's already been declared in wp-includes/rss.php.

Not sure what to do about this one aside from moving fetch_rss() into wp-includes/pluggable.php.

Change History (3)

comment:1 @lloydbudd7 years ago

  • Milestone set to 2.5

comment:2 @technosailor7 years ago

On the flip side, I'm using a homemade plugin to replace magpie using the load_feed_engine hook perfectly fine...

comment:3 @johnbillion7 years ago

  • Milestone 2.5 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing as invalid because you can in fact declare the functions in wp-includes/rss.php with a plugin by using the load_feed_engine hook. I was staring right at it but wasn't using it.

Thanks technosailor!

Note: See TracTickets for help on using tickets.