WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 2 months ago

#53697 closed defect (bug) (fixed)

Possible Regression - Border settings not displaying for Button Block

Reported by: daisyo Owned by: peterwilsoncc
Milestone: 5.8.1 Priority: normal
Severity: normal Version: 5.8
Component: Editor Keywords: has-patch fixed-major
Focuses: Cc:

Description

The control to adjust the radius of buttons is not displaying for the button block. There were some design changes to the border settings controls since 5.7 but, as far as I'm aware, the option to set a border radius for a button block should be present in 5.8.

Tested on 5.8-RC4-51460 with Twenty Twenty One and Twenty Fifteen Themes, No active plugins.

Steps to reproduce:

  • Create Post
  • Add Buttons Block to content
  • Switch to single Button block
  • Observe that border settings are not present in the block settings panel

Attachments (4)

missing-border-5-8.png (22.4 KB) - added by daisyo 3 months ago.
Border settings not present in 58
button-border-5-7.png (20.5 KB) - added by daisyo 3 months ago.
Border settings present in 5.7
features-5.8.png (29.2 KB) - added by Mamaduka 3 months ago.
features-gutenberg.png (126.7 KB) - added by Mamaduka 3 months ago.

Download all attachments as: .zip

Change History (20)

@daisyo
3 months ago

Border settings not present in 58

@daisyo
3 months ago

Border settings present in 5.7

#1 @priethor
3 months ago

I can reproduce the ticket as described with versions 5.7.2 (has border settings) and 5.8-RC4-51460 (doesn't have border settings).

#2 @desrosj
3 months ago

  • Component changed from General to Editor
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 5.8.1
  • Version set to trunk

I am also able to reproduce. Moving this to 5.8.1 for now, but this will likely require a report to be opened upstream.

This ticket was mentioned in Slack in #core-editor by desrosj. View the logs.


3 months ago

#4 @Mamaduka
3 months ago

It looks like the "border" feature isn't enabled. I can see the BorderPanel component in React DevTools, but it returns early because of this.

The attached screenshots showcase the difference between Gutenberg and 5.8 features.

WordPress 5.8

Gutenberg 11.1

I tried updating wp-includes/theme.json but this had no effect. So I assume there's another place where allowed features are listed.

This ticket was mentioned in PR #1513 on WordPress/wordpress-develop by Mamaduka.


3 months ago

  • Keywords has-patch added; needs-patch removed

Trac ticket: https://core.trac.wordpress.org/ticket/53697

Adds missing border setting and enables it for Button block.

I've only included border-radius settings. I wasn't sure about the others.

#6 @prbot
3 months ago

youknowriad commented on PR #1513:

@nosolosw @jorgefilipecosta

#7 @prbot
3 months ago

bgardner commented on PR #1513:

Any chance this can make its way into the 5.8.1 milestone, given that it’s a regression and takes away an option that was previously there?

#8 @mikeschroder
3 months ago

@bgardner: I agree we should fix it in 5.8.1 if possible.

Just a quick note that it is in the milestone:
https://core.trac.wordpress.org/ticket/53697#comment:2

#10 @jorgefilipecosta
3 months ago

  • Resolution set to fixed
  • Status changed from new to closed

#11 @desrosj
3 months ago

  • Keywords fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for backporting.

#12 @peterwilsoncc
3 months ago

  • Owner set to peterwilsoncc
  • Resolution set to fixed
  • Status changed from reopened to closed

In 51547:

Block Editor: Add missing border setting on button block.

This commit fixes a regression on WordPress 5.8 that made the border radius setting on the buttons block disappear.

Props Mamaduka, daisyo, priethor, desrosj, mikeschroder.
Merges [51538] to the 5.8 branch.
Fixes #53697.

#13 @desrosj
3 months ago

#53881 was marked as a duplicate.

This ticket was mentioned in Slack in #core-editor by mamaduka. View the logs.


3 months ago

This ticket was mentioned in Slack in #core by anthonyeden. View the logs.


2 months ago

#16 @desrosj
2 months ago

#53896 was marked as a duplicate.

Note: See TracTickets for help on using tickets.