WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5370 closed defect (bug) (invalid)

No confirmation on deleting posts in Manage, Posts

Reported by: demetris Owned by: mdawaffe
Milestone: Priority: normal
Severity: major Version: 2.3.1
Component: Administration Keywords:
Focuses: Cc:

Description

Posts are deleted immediately in Manage, Posts, without any confirmation dialog.

Tried with two different accounts, admin and editor.

Tested on Windows XP SP2 with Firefox 3, Opera 9.5 and Internet Explorer 6.

I don't know what the previous behaviour was, before 2.3.1.

Greetings,
Demetris

Change History (12)

comment:1 johnbillion6 years ago

Demetris, thanks for the bug report, but I'm unable to reproduce this. I get a nice little confirmation dialog. Have you tried disabling all your plugins and trying again? A plugin may be interfering.

comment:2 demetris6 years ago

Thank you!

I thought of the plugins just after submitting the "bug". :-)

I just disabled all of them, I reverted to the default theme, and also re-enabled the visual editor, but I'm not seeing any difference. The problem persists.

The blog is this: http://op111.net/

It is a test site, mostly vanilla, and the only changes I can remember making are in index.php:

<?php
/* Short and sweet */
define('WP_USE_THEMES', true);
require('./wp/wp-blog-header.php');
?>

and also chaning the name of Blogroll in the database, from Blogroll to Links.

I'll look into it again later.

Greetings,
Demetris

NOTE. The problem only appears when I click Delete in Manage, Posts, i.e. in: wp-admin/edit.php

If I first click Edit (in Manage, Posts or in the post page) and then Delete, I DO get the confirmation dialog.

comment:3 demetris6 years ago

Update:

The problem occurs on an *addon* domain on a hostmonster.com account. I did a test install on the default domain, and everything seemed to be fine.

The root directory of this *addon* domain is:

/home/username/public_html/op111/

While for the default domain it is:

/home/username/

I hope this information is relevant and useful.

Greetings,
Demetris

comment:4 follow-up: JeremyVisser6 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Hmm, go to Options → General, and check that your "WordPress URL" is set to your subdomain correctly.

Oh, and this sounds like an issue for the forums, not Trac.

comment:5 lloydbudd6 years ago

  • Milestone 2.5 deleted

comment:6 xknown6 years ago

  • Resolution worksforme deleted
  • Severity changed from critical to major
  • Status changed from closed to reopened

I was able to reproduce this issue on trunk (rev 6346).

It's related to [6213] where jQuery was introduced for list manipulation and deleteSomething was removed from onclick event of "Delete" links (it affects to Post/Page/Link management). However confirm dialogs are not still implemented.

comment:7 Viper007Bond6 years ago

  • Milestone set to 2.4

comment:8 Viper007Bond6 years ago

  • Component changed from General to Administration

comment:9 ryan6 years ago

  • Owner changed from anonymous to mdawaffe
  • Status changed from reopened to new

Right, AYS is still on the todo.

comment:10 in reply to: ↑ 4 demetris6 years ago

Replying to JeremyVisser:

Hmm, go to Options → General, and check that your "WordPress URL" is set to your subdomain correctly.

Oh, and this sounds like an issue for the forums, not Trac.

Thanks! I changed the WordPress URL (it was the same as the blog URL) to:

http://www.main-domain.tld/wordpress-dir

... and now I get confirmation dialogs.

comment:11 mdawaffe6 years ago

  • Resolution set to invalid
  • Status changed from new to closed

It was a valid issue - but no longer. The new design doesn't have any delete actions for single posts, pages, links, categories, tags, or link categories.

We only have one-off delete actions for comments, and I think the consensus for comments is to not have AYS.

comment:12 lloydbudd6 years ago

  • Milestone 2.5 deleted
Note: See TracTickets for help on using tickets.