WordPress.org

Make WordPress Core

Opened 2 months ago

Closed 2 months ago

#53704 closed defect (bug) (reported-upstream)

Query Loop Block doesn’t see tags

Reported by: arskrigitsioniets Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.8
Component: Editor Keywords:
Focuses: Cc:

Description

Query Loop Block doesn’t see part of tags, I have 300+ tags, and looks like ones that in the end of the list this block doesn't see. For example, I can enter Age of Wonders: Planetfall (the first letter in the alphabet) and the block to see that the tag exists. But when I enter Xenonauts 2 (one of the last letters, the block doesn't see it – I can't enter and save the name of the tag.

Attachments (1)

53704-reproduced.gif (3.0 MB) - added by hellofromTonya 2 months ago.
Testing: reproduced issue

Change History (6)

#1 @hellofromTonya
2 months ago

  • Keywords reporter-feedback added

Hello @arskrigitsioniets,

Welcome back to WordPress Core Trac!

I'm not able to reproduce this problem on a fresh install of 5.8. Here's how I set up the template for the Query Loop: Post Title, Post Except, and Post Tags. Then I filtered the post blocks via the Tags Filter in the Query Loop block. All 300 tags were available for filtering.

That said, I may not be testing how you have it setup. Can you share more information to help with further investigation? Specifically:

  • What is the block structure of the Query Loop?
  • Where are you noticing the tags not selectable?
  • Sharing a gif or screen recording can help contributors follow your workflow as they investigate.

#3 @arskrigitsioniets
2 months ago

I recorded a video with the process: https://youtu.be/lKlYlMZ6Mx0
As you can see, the tag Xenonauts 2 exists, I attach it to the post. Then I try to attach it to Query Loop and nothing happens.

I also can't reproduce it on a clean install, I have this only on my active site. I tried to disable all plugins, it doesn't help.

@hellofromTonya
2 months ago

Testing: reproduced issue

#4 @hellofromTonya
2 months ago

  • Keywords reporter-feedback removed

@arskrigitsioniets Thank you for sharing the video. I was able to reproduce the problem as shown 53704-reproduced.gif. I'll open an issue upstream in the Gutenberg GitHub repository to report it there for resolution.

#5 @hellofromTonya
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

This has been reported upstream. @arskrigitsioniets you can follow its progress in this issue https://github.com/WordPress/gutenberg/issues/33581.

I'm going to close this ticket. Why? The issue will be addressed in the Gutenberg repository. If however the issue is related to Core, then it can be reopened.

Note: See TracTickets for help on using tickets.