Make WordPress Core

Opened 3 years ago

Last modified 3 days ago

#53707 reopened defect (bug)

Edit critical error message for situations when email is not received

Reported by: ipajen's profile ipajen Owned by:
Milestone: 6.7 Priority: normal
Severity: normal Version: 5.8
Component: Upgrade/Install Keywords: needs-copy-review has-patch
Focuses: ui-copy Cc:

Description (last modified by sabernhardt)

Fatal error when trying to update to WordPress 5.8 from (5.7.2) with PHP8. Tried to disable all plugins and same problem on two different websites (same hosting), also no e-mail is sent out about critical error to site admin e-mail.

Update WordPress
Downloading update from https://downloads.wordpress.org/release/sv_SE/wordpress-5.8.zip
The authenticity of wordpress-5.8.zip could not be verified as no signature was found.
Unpacking the update…

Fatal error: Maximum execution time of 30 seconds exceeded in /.../wp-admin/includes/class-wp-filesystem-direct.php on line 76
There has been a critical error on this website. Please check your site admin email inbox for instructions.

`

Change History (15)

#1 @desrosj
3 years ago

  • Component changed from General to Upgrade/Install
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @ipajen, Welcome to Trac!

It seems like your server experienced a timeout when trying to upgrade. This request is better suited for the WordPress.org support forums, as this is not a bug in WordPress itself.

This forum post has all the information you need to fix this issue, and some other information specific to the 5.8 update.

#2 @ipajen
3 years ago

  • Resolution invalid deleted
  • Severity changed from major to minor
  • Status changed from closed to reopened
  • Summary changed from Fatal error when trying to update to WordPress 5.8 class-wp-filesystem-direct.php on line 76 to Critical error E-Mail is not sent out when trying to update to WordPress 5.8 class-wp-filesystem-direct.php on line 76

@desrosj thanks, hostning increased the Maximum Execution time and it worked to update, but When this error accourd it still dident send out a email about critical error, (When i make another critical error from a bad plugin it send out the enail) so i still believe There is a bug about email is not sent out When ciritical error in the update process.

#3 @desrosj
3 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

It's likely that you did not receive the email because there was an incomplete update. Please read through the post linked above and find the section about manually upgrading.

If you need more assistance, please open a support forums ticket.

#4 @ipajen
3 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

@desrosj The update issue it self is solved. But my bug report is about The text "Please check your site admin email inbox for instructions." should not be printed if code cant handle the exception and send the e-mail? Best would be that e-mail would be sent out as excepted from the printed message. So the bug still is there. Thank you.

#5 @sabernhardt
5 months ago

  • Description modified (diff)
  • Focuses ui-copy added
  • Keywords needs-copy-review added
  • Milestone set to Future Release
  • Severity changed from minor to normal
  • Summary changed from Critical error E-Mail is not sent out when trying to update to WordPress 5.8 class-wp-filesystem-direct.php on line 76 to Edit critical error message for situations when email is not received

Several similar complaints about not receiving the email have been raised on Trac.

The second sentence could be replaced with something like this, with a link to the forums:
"Your site admin email inbox should receive a message with instructions for troubleshooting. If you need further assistance, please try the support forums."

That would make the full message:

There has been a critical error on this website. Your site admin email inbox should receive a message with instructions for troubleshooting. If you need further assistance, please try the support forums.

Learn more about troubleshooting WordPress.


Also related: #52014

This ticket was mentioned in PR #6032 on WordPress/wordpress-develop by @sabernhardt.


5 months ago
#6

  • Keywords has-patch added
  • Adjusts language for cases in which the email is not received
  • Adds link to the support forums for more help (before the link to the troubleshooting article)

Trac 53707

@mukesh27 commented on PR #6032:


4 months ago
#7

Thanks, @sabernhardt. The approach looks good to me, especially regarding adding the support link.

#8 @sabernhardt
4 months ago

  • Milestone changed from Future Release to 6.6

This ticket was mentioned in Slack in #core-upgrade-install by afragen. View the logs.


2 months ago

@afragen commented on PR #6032:


2 months ago
#10

Is there a reason for changing the original message?

#11 @afragen
2 months ago

I'm not sure why the original message is being changed as opposed to simply adding the sentence about looking to the support forums for assistance.

@sabernhardt commented on PR #6032:


2 months ago
#12

Yes, there is a reason, but the text revision is probably not as valuable as I thought it was two months ago. The edited sentence _hints_ that although sending the message should succeed now, receiving it still might fail (which would not be a Core bug).

Adding the support forums sentence with the link directs people where to research and/or ask for help, and that could be sufficient without editing the rest.

#13 @webcommsat
2 weeks ago

On the copy review side, I do not think the revised text adds much value especially if it may add an unnecessary bug to be raised for what could be a local spam or email update and setting issue. I think the direct signposting link would help.

#14 @sabernhardt
2 weeks ago

The second sentence is restored to how it had been, and the support forums sentence matches the text within a similar string. This is the updated message:

There has been a critical error on this website. Please check your site admin email inbox for instructions. If you continue to have problems, please try the support forums.

Learn more about troubleshooting WordPress.

Last edited 2 weeks ago by sabernhardt (previous) (diff)

#15 @sabernhardt
3 days ago

  • Milestone changed from 6.6 to 6.7

Unless someone wants to commit this before string freeze for 6.6, this can be delayed to 6.7.

Note: See TracTickets for help on using tickets.