WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#5371 closed defect (bug) (duplicate)

Smart quotes broken when surrounding links

Reported by: glesik Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.3.1
Component: Formatting Keywords:
Focuses: Cc:

Description

if I put a link in quotes, e.g.

"<a href="http://mysite.com">mysite</a>"

WordPress doesn't put the proper 'curly' quote after the link text. So the result looks like “mysite“ instead of “mysite”.

Change History (6)

comment:1 @lloydbudd7 years ago

  • Milestone changed from 2.3.2 to 2.5

comment:2 @Denis-de-Bernardy6 years ago

  • Component changed from General to Formatting
  • Owner anonymous deleted

comment:3 @janeforshort5 years ago

  • Milestone changed from 2.9 to Future Release

Punting, no patch.

comment:4 @johnbillion4 years ago

  • Cc johnbillion@… added

comment:5 @johnbillion4 years ago

  • Keywords quotes smart magic fancy links removed
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as dupe of #10606 which has more discussion.

comment:6 @nacin4 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.