WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 2 months ago

Last modified 2 weeks ago

#53725 closed defect (bug) (fixed)

Classic Editor: 'new-post-slug' input missing a label

Reported by: sabernhardt Owned by: audrasjb
Milestone: 5.9 Priority: normal
Severity: normal Version:
Component: Editor Keywords: has-patch commit
Focuses: accessibility, coding-standards Cc:

Description

The input for changing the permalink of a post does not have a label in the Classic Editor.

Attachments (2)

53725.diff (859 bytes) - added by sabernhardt 6 months ago.
Capture d’écran 2021-11-19 à 23.05.16.png (284.4 KB) - added by audrasjb 2 months ago.
Tested on VoiceOver

Download all attachments as: .zip

Change History (20)

@sabernhardt
6 months ago

#1 @sabernhardt
6 months ago

  • Keywords has-patch added

The patch includes a spellcheck attribute, which was suggested on #50499.

Also, I think the translation needs something else. I chose the existing string "URL Slug" instead of new text, and I still have English there with a French profile.

#2 @audrasjb
6 months ago

The change looks good to me, thanks @sabernhardt!

I can confirm the URL Slug string already exists and is translated in fr_FR (https://translate.wordpress.org/projects/wp/dev/fr/default/?filters%5Bstatus%5D=either&filters%5Boriginal_id%5D=7578448&filters%5Btranslation_id%5D=62892203) so I'm not sure why it's not translated. Maybe because the existing occurence comes from the block editor?

Last edited 6 months ago by audrasjb (previous) (diff)

This ticket was mentioned in Slack in #core by sabernhardt. View the logs.


3 months ago

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


2 months ago

#5 @sabernhardt
2 months ago

  • Keywords needs-testing added

This ticket was mentioned in Slack in #core-test by boniu91. View the logs.


2 months ago

This ticket was mentioned in Slack in #core-test by boniu91. View the logs.


2 months ago

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


2 months ago

#9 @sabernhardt
2 months ago

Note that the proposed label is not visual, so it would need testing with a screen reader.

Testing the extra part to make sure the browser does not run spellcheck on the input (when enabled) might be easier visibly, so you can verify the jagged underline no longer shows under an intentionally misspelled word.

#10 @audrasjb
2 months ago

  • Owner set to audrasjb
  • Status changed from new to reviewing

Self-assigning for proper testing using a screen-reader.

@audrasjb
2 months ago

Tested on VoiceOver

#11 @audrasjb
2 months ago

I tested on a visual browser to make sure it doesn't trigger spellcheck on the input field, and it looks good to me. Also, the label is correctly rendered at least on VoiceOver.

#12 @audrasjb
2 months ago

  • Keywords needs-testing removed

#14 @audrasjb
2 months ago

Just added a GitHub PR to run checks, and it appears slug_label needs to be defined. Fixing this right now :)

#15 @audrasjb
2 months ago

  • Keywords commit added

Tests are passing now. Ready for commit.

#16 @audrasjb
2 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 52225:

Editor: Add missing label to new-post-slug input on Classic Editor.

Previously, the input for changing the permalink of a post does not have a label in the Classic Editor. This change adds a visually hidden label. It also makes sure browsers do not run spellcheck on the input field.

Props sabernhardt.
Fixes #53725.

This ticket was mentioned in Slack in #core-test by monikarao. View the logs.


2 months ago

Note: See TracTickets for help on using tickets.