WordPress.org

Make WordPress Core

Opened 2 months ago

Closed 2 months ago

#53739 closed defect (bug) (invalid)

Erros in Widget Blocks

Reported by: siteright Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.8
Component: Widgets Keywords:
Focuses: Cc:

Description

One of my websites is showing block errors and I cannot get the widgets to work or update them.

The "custom_html" block was affected by errors and may not function properly. Check the developer tools for more details.

The "recent-posts" block was affected by errors and may not function properly. Check the developer tools for more details.

The "categories" block was affected by errors and may not function properly. Check the developer tools for more details.

The "media_image" block was affected by errors and may not function properly. Check the developer tools for more details.

I have seen a few people on forums posting the same issues.
I have tried reinstalling the update and it has not fixed the issue.

Plugins on the site are as follows:
Antispam Bee
Contact Form 7
Envato Market
GDPR Cookie Consent
Litespeed Cache
Loginizer
Minimal Coming Soon and Maintenance Mode
Really Simple SSL
Yoast SEO
Salient Theme Plugins

Attachments (2)

Screenshot 2021-07-22 at 14.56.43.png (42.2 KB) - added by siteright 2 months ago.
Error Screenshot
53739-reproduce-attempt1.gif (8.6 MB) - added by hellofromTonya 2 months ago.
Testing: attempt to reproduce problem with all plugins except Salient and using Twenty Twenty-One theme

Change History (7)

@siteright
2 months ago

Error Screenshot

#1 @hellofromTonya
2 months ago

  • Component changed from General to Widgets
  • Keywords needs-testing removed

@hellofromTonya
2 months ago

Testing: attempt to reproduce problem with all plugins except Salient and using Twenty Twenty-One theme

#2 @hellofromTonya
2 months ago

Test: Attempt to reproduce reported problem

Env:

  • OS: macOS Big Sur v11.4
  • Browser: Chrome Version 91.0.4472.114
  • Localhost: Local running on nginx, MySQL 8.0.16, and PHP versions 7.3.5 and 8.0
  • WordPress: 5.8
  • Activated plugins: all of the plugins listed except for Salient Theme Plugins which is part of a premium theme package
  • Theme: Twenty Twenty-One

Setup:

  • Activated Classic Widgets plugin to switch to the classic screen
  • Added text and meta widgets
  • Deactivated Classic Widgets plugin

Testing Results:

  • No errors in the browser console
  • Nothing in the error.log
  • Widgets rendered as expected
  • Note: GDPR Cookie Consent added a layer on top of each widget

Unable to reproduce the problem. Might be due to the Salient plugins, theme, or third party script.

#3 @hellofromTonya
2 months ago

  • Keywords reporter-feedback added

Hello @siteright,

Welcome to WordPress Core Trac! I'm sorry you're having issues after upgrading to 5.8.

Thank you for the list of activated plugins on your site. That was very helpful!

I attempted to reproduce the problem (see my testing notes) and was not able to reproduce it. I don't have a copy the Salient plugins as I think these are packaged with premium themes.

I suspect the problem is with either the Salient plugins or the theme. But let's confirm.

To further diagnose, please do the following steps:

  1. Deactivate the Salient plugins
  2. Switch to a default theme such as Twenty Twenty-One
  3. Go back to the Appearance > Widgets screen
  4. Do the errors go away?

If yes, then either the Salient plugins or the theme is causing the problem.
If no, please do the following to help with further investigation:

  • In your browser, open the developer tools. For example, using Chrome or Firefox, right click and then select Inspect.
  • Then go to Console tab.
  • Do a screenshot of the what's in the console area (errors can be reported here).
  • Then add that screenshot

Here's more troubleshooting information https://wordpress.org/support/topic/read-this-first-wordpress-master-list/.

#4 follow-up: @siteright
2 months ago

Hello Tonya,

Thank you for your response.

I don't think it's the Salient Theme plugins that come bundled with the theme package as I am running the same theme on other websites without issue.

I deactivated all of the plugins and replaced the wp-admin and wp-includes files in cpanel, logged back into the website and reactivated the plugins which seems to have fixed the issue.

I am also now noticing on various other sites the following messages:

  • Old WordPress core file not removed during update: wp-includes/css/dist/editor/editor-styles-rtl.css
  • Old WordPress core file not removed during update: wp-includes/css/dist/editor/editor-styles-rtl.min.css
  • Old WordPress core file not removed during update: wp-includes/css/dist/editor/editor-styles.css
  • Old WordPress core file not removed during update: wp-includes/css/dist/editor/editor-styles.min.css

Please advise.

Many thanks.

#5 in reply to: ↑ 4 @hellofromTonya
2 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from assigned to closed

Replying to siteright:

I am also now noticing on various other sites the following messages:

  • Old WordPress core file not removed during update: wp-includes/css/dist/editor/editor-styles-rtl.css
  • Old WordPress core file not removed during update: wp-includes/css/dist/editor/editor-styles-rtl.min.css
  • Old WordPress core file not removed during update: wp-includes/css/dist/editor/editor-styles.css
  • Old WordPress core file not removed during update: wp-includes/css/dist/editor/editor-styles.min.css

This is being tracked in ticket #53702.

Replying to siteright:

I deactivated all of the plugins and replaced the wp-admin and wp-includes files in cpanel, logged back into the website and reactivated the plugins which seems to have fixed the issue.

That's great! Thanks for sharing the steps you took and how you resolved the issue.

Closing this ticket as reinstalling fixed the problem.

Note: See TracTickets for help on using tickets.