WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 5 months ago

#53763 closed defect (bug) (invalid)

No default font setting?

Reported by: waypasthadenough Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords:
Focuses: Cc:

Description

This is VERY RELEVANT TO ME. As far as I can tell there's no way to set a default font in classic editor. Why not? I did try to search for such with no luck online in any forum I saw. But then something that basic should be simple.

Also, I tried blocks when they were first intro'd. The experience was hideous and like trying to drag an island through a molasses ocean. If I'm forced to use that garbage in the future I'll just look for another editor.

Change History (2)

#1 @joyously
5 months ago

This is not a bug.
The editor is for content. The theme is for styling.
To change your font, use a theme with that option or a plugin for loading fonts.

#2 @hellofromTonya
5 months ago

  • Component changed from General to TinyMCE
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hello @waypasthadenough,

Welcome to WordPress Core Trac!

As @joyously noted, the default font is set in the theme. This is intentional by design, meaning themes determine the styling of the site.

How can you set the default font?

Setting the default font family, color, and size are all customizable things that can be set directly through CSS or by using a plugin or theme that adds selection fields to an admin UI screen. Some themes like Twenty Twenty-One use global CSS variables to set these defaults in the :root.

This Trac is for reporting and tracking issues with WordPress Core itself. It's not well suited for customization or site support like requests.

Where can you get additional help? The Support forums are a better option: https://wordpress.org/support/forums/. Also the Plugin and Theme repositories on WordPress.org are another resource to help you find options that fit your needs.

As this is not a defect with WordPress, closing this ticket.

Note: See TracTickets for help on using tickets.