WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#53808 closed defect (bug) (duplicate)

Got "/^(?:[\d]+|me$/: Unterminated group" error after wordpress upgrade

Reported by: ranjitp Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.6
Component: REST API Keywords: needs-patch reporter-feedback
Focuses: javascript, rest-api Cc:

Description (last modified by SergeyBiryukov)

I have got a Invalid regular expression. But when i removed the groupPattern ? '' + groupPattern + '$' : component, 'i' in the line 81 from the file node_modules/wpapi/lib/route-tree.js. It is working fine. I have upgrade the WP. I got that error after that.

Change History (3)

#1 @SergeyBiryukov
3 months ago

  • Keywords reporter-feedback added

Hi there, welcome to WordPress Trac! Thanks for the report.

It looks like the issue is with the wpapi node package, which is a JavaScript Client for the WordPress REST API, and not a part of WordPress core.

Does the issue still happen with all plugins disabled and a default theme (Twenty Twenty-One) activated?

#2 @SergeyBiryukov
3 months ago

  • Description modified (diff)

Related: #51467

#3 @TimothyBlynJacobs
3 months ago

  • Component changed from General to REST API
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Severity changed from critical to normal
  • Status changed from new to closed
  • Version changed from 5.7.2 to 5.6

Yeah this is a dupe of #51467, it needs to be fixed upstream in the node-wpapi library.

Note: See TracTickets for help on using tickets.