WordPress.org

Make WordPress Core

Changes between Initial Version and Version 19 of Ticket #53811


Ignore:
Timestamp:
08/31/2021 08:20:34 PM (6 weeks ago)
Author:
hellofromTonya
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #53811

    • Property Status changed from new to reopened
    • Property Component changed from General to Widgets
    • Property Summary changed from Rename `retrieve_widgets` to `recover_lost_widgets` to Rename `retrieve_widgets` to `sync_registered_widgets`
    • Property Owner set to hellofromTonya
    • Property Milestone changed from Awaiting Review to 5.8.1
    • Property Keywords has-unit-tests commit added
  • Ticket #53811 – Description

    initial v19  
    11We have a function called `retrieve_widgets`. The name suggests that it's a getter, yet it updates the database by assigning the orphaned widgets to an inactive sidebar.
    22
    3 The name is misleading and it bit us in https://github.com/WordPress/gutenberg/issues/33335#issuecomment-879903958 and https://core.trac.wordpress.org/ticket/53657.
     3The name is misleading and it bit us in https://github.com/WordPress/gutenberg/issues/33335#issuecomment-879903958 and #53657.
    44
    5 I propose we deprecate the current name and move forward with a new one which communicates the intention in a clearer way: `recover_lost_widgets`.
     5I propose we deprecate the current name and move forward with a new one which communicates the intention in a clearer way: `sync_registered_widgets`.
    66
     7Part of the epic ticket #53816.