Make WordPress Core

Opened 4 months ago

Last modified 3 months ago

#53811 closed defect (bug)

Rename `retrieve_widgets` to `recover_lost_widgets` — at Initial Version

Reported by: zieladam Owned by:
Milestone: 5.9 Priority: normal
Severity: normal Version:
Component: Widgets Keywords: has-patch
Focuses: docs Cc:


We have a function called retrieve_widgets. The name suggests that it's a getter, yet it updates the database by assigning the orphaned widgets to an inactive sidebar.

The name is misleading and it bit us in https://github.com/WordPress/gutenberg/issues/33335#issuecomment-879903958 and https://core.trac.wordpress.org/ticket/53657.

I propose we deprecate the current name and move forward with a new one which communicates the intention in a clearer way: recover_lost_widgets.

Change History (0)

Note: See TracTickets for help on using tickets.