WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#5385 closed defect (bug) (invalid)

Page Passwords Not Working

Reported by: sarmadhassan Owned by:
Milestone: Priority: high
Severity: normal Version: 2.3.1
Component: General Keywords:
Focuses: Cc:

Description

The page password is not working in wordpress. When i type in the correct password, the page just refreshes but dont went on to show the page content. Kindly help us in this regard.

Change History (12)

comment:1 follow-up: @Nazgul7 years ago

  • Keywords reporter-feedback added
  • Milestone set to 2.5
  • Priority changed from high to normal
  • Severity changed from critical to normal

I'm unable to reproduce this with the meager info given.

Could you give some additional information, like:

  • the version of WordPress you're runnimg,
  • exact reproduction steps,
  • the platform you're running (Win/*nix, PHP Version, ...)
  • any other useful information.

comment:2 in reply to: ↑ 1 @sarmadhassan7 years ago

Replying to Nazgul:

I'm unable to reproduce this with the meager info given.

Could you give some additional information, like:

  • the version of WordPress you're runnimg,
  • exact reproduction steps,
  • the platform you're running (Win/*nix, PHP Version, ...)
  • any other useful information.

latest 2.3.1
1) enter password for a page
2) access the page
3) the page asks for password
4) i enter correct password
5) it prompts for password again and again and doesnt let me see page content

Platform
Type Debian
MySQL Version
MySQL Version 5.0.45
Perl Version
Perl 5.8.8
PHP Version
PHP 4.4.7

all my plugins are up to date as well

comment:3 follow-up: @johnbillion7 years ago

Hi samandhassan, does the problem still occur if you deactivate all your plugins?

comment:4 in reply to: ↑ 3 ; follow-up: @sarmadhassan7 years ago

Replying to johnbillion:

Hi samandhassan, does the problem still occur if you deactivate all your plugins?

Sir! no the problem doesnt exist. When i deactivate a plugin called "get-recent-comments' the problem is no more there. Can you please tell me exactly which files i need to upload here?

comment:5 in reply to: ↑ 4 ; follow-up: @DD327 years ago

  • Keywords reporter-feedback removed
  • Milestone 2.5 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Replying to sarmadhassan:

When i deactivate a plugin called "get-recent-comments' the problem is no more there.

If thats the case then you'll need to check if there is an updated version of that plugin(and install it), Or get in touch with the plugins author to get the problem fixed as its not a WordPress issue.

In the meantime, I guess you'll have to either decide if you want that plugins functionality, or password protected posts.

I'm going to close this ticket as invalid since its not a WP issue. Feel free to re-open it if more details come to light that indicate its a WP issue.

comment:6 in reply to: ↑ 5 ; follow-up: @sarmadhassan7 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to DD32:

Replying to sarmadhassan:

When i deactivate a plugin called "get-recent-comments' the problem is no more there.

If thats the case then you'll need to check if there is an updated version of that plugin(and install it), Or get in touch with the plugins author to get the problem fixed as its not a WordPress issue.

In the meantime, I guess you'll have to either decide if you want that plugins functionality, or password protected posts.

I'm going to close this ticket as invalid since its not a WP issue. Feel free to re-open it if more details come to light that indicate its a WP issue.

Sir, actually i have tested this plugin with several wordpress blogs and the page password works fine. But particularly with my wordpress source it has issues.. can you please tell me what could be problem. You can google around to see various people talking about this prob. but there is no solution to this yet.

Best Regards,
Sarmad

comment:7 in reply to: ↑ 6 ; follow-up: @DD327 years ago

Replying to sarmadhassan:

i have tested this plugin with several wordpress blogs and the page password works fine.

Ok, I'll leave the ticket as it is, However, If it works when the plugin is disabled, Then To me, Its a plugin issue. Just because a plugin works fine on one install, doesnt mean it'll work fine on another, If I were you i'd get in touch with the Author and try to work with them to fix the issue.

You can re-install WordPress from scratch if you like(Delete all files exept wp-config.php and wp-content, Re-upload the latest files) and then try again, But i dont think you'll have much more luck.

comment:8 in reply to: ↑ 7 ; follow-up: @Viper007Bond7 years ago

Replying to DD32:

If it works when the plugin is disabled, Then To me, Its a plugin issue.

This is correct. This ticket is invalid and should be closed as it's strictly a plugin issue.

I don't want to get in a closing war though, so I'm not going to be the one to do it. :)

comment:9 in reply to: ↑ 8 ; follow-up: @sarmadhassan7 years ago

Replying to Viper007Bond:

Replying to DD32:

If it works when the plugin is disabled, Then To me, Its a plugin issue.

This is correct. This ticket is invalid and should be closed as it's strictly a plugin issue.

I don't want to get in a closing war though, so I'm not going to be the one to do it. :)

lol.. i appreciate the helpers here.. iam going to give it a try as DD32 stated.

comment:10 in reply to: ↑ 9 ; follow-up: @sarmadhassan7 years ago

  • Priority changed from normal to high

i did what DD32 stated.. the problem remains there.. the plugin i said is working perfectly with other blogs..

I really dont understand where the f* problem lies.. wordpress works fine in its own way when installed elsewhere with the same plugin.. why it all gets out of order with my particular blog????? am really getting mad..

any admin here please gime your contact so i can provide complete access to the source.

comment:11 in reply to: ↑ 10 @DD327 years ago

Replying to sarmadhassan:

I really dont understand where the f* problem lies.. wordpress works fine in its own way when installed elsewhere with the same plugin.. why it all gets out of order with my particular blog????? am really getting mad..

The problem most likely lies in a conflict between your webhost's setup and the plugin, Most WP devs wouldnt know how the plugin works, so your best bet would be the plugin author, however if they cant help you, you might have to see if anyone else puts their hand up to investigate it for you.

comment:12 @johnbillion7 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed
  • Version set to 2.3.1

sarmandhassan, sorry but this isn't the place for this discussion. It is evident that the issue is caused either by the get-recent-comments plugin, or a conflict with the plugin and your server setup, and therefore this is not a WordPress issue.

You'll be much better off opening a ticket on the WordPress support forums at http://wordpress.org/support/ as vastly more people read those forums and will be more likely to be able to help. As DD32 points out, contacting the plugin author wouldn't hurt either.

Closing as invalid, please don't reopen unless someone can provide evidence that it is a WordPress issue.

Note: See TracTickets for help on using tickets.