WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#5394 closed defect (bug) (duplicate)

Invalid XHTML 'correction'

Reported by: docwhat Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: wpautop
Focuses: Cc:

Description

What Happens:

Enter the following into a post or page:

<div>
 <form>
 </form>
 </div>

View the page and notice that the resulting HTML is:

<div>
<form>
  </form>
</p></div>

What I Expected:

I expect the HTML to look like so:

<div>
  <form>
  </form>
</div>

Change History (6)

comment:1 lloydbudd6 years ago

  • Keywords wpautop added

comment:2 follow-up: santosj6 years ago

Isn't this an duplicate?

comment:3 in reply to: ↑ 2 docwhat6 years ago

Replying to santosj:

Isn't this an duplicate?

Of which bug? I didn't see any open bugs that matched it. There were some closed bugs that looked similar but (unless this is a regression) isn't the same.

Ciao!

comment:4 santosj6 years ago

Sorry. See also #4857.

comment:5 docwhat6 years ago

That does look similar. Is there a way I can get the changeset number so I could patch my copy and see if it fixes it?

Ciao!

comment:6 DD326 years ago

  • Milestone 2.6 deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 2.3.1 deleted

The test-case provided in this ticket has been resolved.

<div>
<form>
 </form>
</div>

comes out properly.

Closing as Dupe of #4857 (as it deals with the extra </p>)

Note: See TracTickets for help on using tickets.