WordPress.org

Make WordPress Core

Opened 2 months ago

Last modified 5 weeks ago

#53985 reopened enhancement

Change suggested maximum image size to 2560 pixel (like big image threshold)

Reported by: zodiac1978 Owned by:
Milestone: 5.9 Priority: normal
Severity: normal Version:
Component: Media Keywords: needs-copy-review has-patch
Focuses: Cc:

Description

In #47872 we introduced and in #49280 we refined the error message for a broken image upload to this text:

Post-processing of the image failed likely because the server is busy or does not have enough resources. Uploading a smaller image may help. Suggested maximum size is 2500 pixels.

But in #47873 the big image threshold is set to 2560 pixel which is not 2500 pixel but not much away.

I think this could be confusing for beginners. Which is the recommended maximum size? 2560 or 2500 pixels?

Would it make sense to change the last sentence to "Suggested maximum size is 2560 pixels."?

Attachments (1)

53985.diff (1.2 KB) - added by zodiac1978 2 months ago.
Change suggested maximum size to 2560 pixel instead of 2500 pixel

Download all attachments as: .zip

Change History (10)

#1 @SergeyBiryukov
2 months ago

  • Milestone changed from Awaiting Review to 5.9

#2 @zodiac1978
2 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #53984.

#3 @zodiac1978
2 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Closed the wrong ticket :(

Created this ticket twice due to a internal server error on submission.

Last edited 2 months ago by zodiac1978 (previous) (diff)

#4 @zodiac1978
2 months ago

#53984 was marked as a duplicate.

@zodiac1978
2 months ago

Change suggested maximum size to 2560 pixel instead of 2500 pixel

#5 @mukesh27
2 months ago

  • Keywords has-patch added; needs-patch removed

Agreed with @zodiac1978. We have to use 2560 pixels instead of 2500 pixels so others don't get confuse.

Let's wait for core dev feedback then will make it commit

#6 @SergeyBiryukov
2 months ago

My initial though was that 2500 might have been chosen as a reasonable, easy-to-remember value below the default big_image_size_threshold filter value (2560), to avoid using additional resources for post-processing.

I was wondering what would happen if the image is exactly 2560 pixels on either side. Looking at [46076] / #47873, scaling the image down to use as the "full" size only happens if it's larger than the threshold value, so suggesting 2560 for consistency should still be fine.

#7 follow-up: @antpb
2 months ago

this came up in the recent Media component meeting. I agree, changing the message to be exactly the value is the right call.

@joyously mentioned that because the value is able to be filtered maybe we should directly use that filterable value in the place where this message mentions the size.

#8 in reply to: ↑ 7 @zodiac1978
2 months ago

Replying to antpb:

@joyously mentioned that because the value is able to be filtered maybe we should directly use that filterable value in the place where this message mentions the size.

Good thought! On the other hand is the error message a warning about an image that is maybe too big to handle for the server. Using the filtered value could give the wrong expression that the filtered value is something WordPress itself is recommending.

If someone uses the filter they should be aware of the implications, but we all know that copying & pasting code snippets happens a lot ...

This ticket was mentioned in Slack in #core-media by antpb. View the logs.


5 weeks ago

Note: See TracTickets for help on using tickets.