Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#54084 closed defect (bug) (invalid)

fatal error

Reported by: reinaldorafaelbriceno's profile reinaldorafaelbriceno Owned by:
Milestone: Priority: normal
Severity: critical Version: 5.8
Component: General Keywords:
Focuses: Cc:

Description

Buenas tardes,
My theme is called crowdpress, I install it to my wordpress, version 5.8, but when trying to activate it I get this fatal error:

Fatal error: Declaration of ECF_FieldRichText::render() must be compatible with ECF_FieldTextarea::render($append = ) in C:\xampp\htdocs\wordpress\wp-content\themes\crowdpress\_framework\custom_fields\fields.php on line 316

Warning: Trying to access array offset on value of type bool in C:\xampp\htdocs\wordpress\wp-includes\class-wp-recovery-mode-email-service.php on line 351

Warning: Trying to access array offset on value of type bool in C:\xampp\htdocs\wordpress\wp-includes\class-wp-recovery-mode-email-service.php on line 352`

La versión php del localhost versión 8.0

Realmente necesito una ayuda para solucionar este error fatal. Agradezco lo que puedan ayudarme

Saludos,

Reinaldo Briceño

Change History (1)

#1 @hellofromTonya
2 years ago

  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hello @reinaldorafaelbriceno,

Welcome to WordPress Core's Trac!

I'm sorry you're having issues with your website. The fatal error message points to a problem within the theme:

Fatal error: Declaration of ECF_FieldRichText::render() must be compatible with ECF_FieldTextarea::render($append = ) in C:\xampp\htdocs\wordpress\wp-content\themes\crowdpress\_framework\custom_fields\fields.php on line 316

It looks like ECF_FieldRichText is a child class of ECF_FieldTextarea (the parent class). ECF_FieldRichText::render() method signature (the parameters it defines) must match its parent. Look at the error message. It shows the parent's render() method has an $append parameter defined. The child class does not or it's signature is different.

Why did this fatal error happen when you installed it on PHP 8? PHP 8 changed method signatures from a Warning to a Fatal Error. I created a snippet to show this in action https://3v4l.org/mPQG1.

The problem is within the theme. Where can you get help? Please reach out to the theme author for support.

Please note that this Trac is used for enhancements and bug reporting for the WordPress Core software, not for individual support questions. The support forums are available for individual support questions https://wordpress.org/support/forums/.

Note: See TracTickets for help on using tickets.